10.5.2 hangs on startup

Discussion in 'macOS' started by aingerso, Feb 12, 2008.

  1. aingerso macrumors newbie

    Joined:
    Feb 12, 2008
    #1
    Hello everyone...

    I've tried searching for a solution but haven't been able to find anything. I downloaded the 10.5.2 software upgrade through the software updater, it logged out of the desktop view of OS X, went to the install screen, and an error message popped up telling me that the installation failed and that the computer needed to be restarted.

    After the restart, the Intel Macbook now hangs on the grey apple-logo screen (i'm letting it run at about 45 minutes now because the progress circle is continuing to spin). Here's what I've tried to do thus far:

    -gone into single user mode and ran /sbin/fsck -fy (it came back okay; rebooted)
    -tried to boot in safe mode (with the shift key) with no success

    I am running a 2.0 GHz Intel Macbook (1st generation) with 1 Gb RAM on 10.5.1 (but unclear which version as of now...)

    Any assistance would be greatly appreciated!
     
  2. aingerso thread starter macrumors newbie

    Joined:
    Feb 12, 2008
    #2
    this has happened to others on the apple forums as well:

    and here:

     
  3. aingerso thread starter macrumors newbie

    Joined:
    Feb 12, 2008
    #3
    another person posted a 'fix' that involved the safe mode boot:

    however, safe mode does not seem to function for my situation.... it is stuck on the grey startup screen with the progress dial spinning...

    can anyone provide any tips or any thoughts at all? do you need more information?
     
  4. mjlanctot macrumors newbie

    Joined:
    Feb 12, 2008
    #4
    same here: can't access safe mode

    I have the same problem. I get the grey screen with the rotating gears (reminds me too much of the hourglass). I suggest apple replaces spinning wheel with a horizontal bar of some finite length that increases to the right so you know its doing something useful.

    I can't start in safe mode or single user mode, but I can start in verbose mode: (command-v held prior to and during startup). I see endless crash reports.

    Why doesn't safe mode work?
     
  5. mjlanctot macrumors newbie

    Joined:
    Feb 12, 2008
    #5
    ok in safe mode i think

    I couldn't get into safe mode but i could get into verbose mode but all i saw were endless crash reports so I cycled the power and tried single mode again (command s) and now i'm into the root.

    what to do now? ....
     
  6. valve macrumors newbie

    Joined:
    Feb 13, 2008
    #6
    Same thing happened to me earlier tonight, loginwindow kept crashing in an endless loop.

    I did two things: I moved aside all thirdparty kernel-extensions (Little Snitch and Parallels-stuff), and I ran 'Repair Permissions' from Disk Utility on my Leopard installdisk. That fixed the problem for me.

    BTW: anyone who started experiencing these problems after installing Office 2008? Or am I just being paranoid? ;-)
     
  7. rmanke macrumors newbie

    Joined:
    Mar 18, 2008
    #7
    Same problem here on a MacBook. Can't start up in any mode at all, it keeps getting into a loop writing crash reports.

    I've reinstalled the OS twice now, trying to get 10.5.2 to install...
     
  8. valve macrumors newbie

    Joined:
    Feb 13, 2008
    #8
    Did you run Repair Permissions from your install-DVD?
     
  9. hob macrumors 68020

    hob

    Joined:
    Oct 4, 2003
    Location:
    London, UK
    #9
    I just got this bug out of the blue today.

    I installed 10.5.2 weeks ago!

    I went to bed light, and put my iMac to sleep (unusually, it's normally crunching some numbers overnight).

    Came back this morning, switched it on, RDC'd into it and it kept asking for a kerberos password. Anyway, it wouldn't let me log in (remotely)

    so I SSH'd in, and told it to reboot.

    Came back to it, and it was stuck on the spinny screen. Turned it off and on again, same.

    Ran in single user mode, did FSCK -fy, file system was modified. Ran it again to be sure, everything was ok. Then i typed "exit" and it booted, right the way up to the end, then said ReportCrashXXXX Saved crashreport.....WindowServer.

    Over and over and over and over!

    I'm going to try reinstall the 10.5.2 combo update over firewire from my MacBook.

    Update: re-installing the 10.5.2 update fixed my problem, good luck to y'all :)
     
  10. esquire360 macrumors regular

    Joined:
    Sep 8, 2007
    #10
    my step mom's iMac is down.... tried permissions, and disk repair = no go, going to boot to external hard drive, run some tests with that.

    grey screen spinning pin-wheel of frustration
     
  11. Binsy macrumors newbie

    Joined:
    Jun 12, 2008
    #11
    Same problem

    I've just bought a new macbook pro laptop yesterday and after filling out my registration details for it in installation, it asked me to restart.

    I did so but now im having the same problem as everyone else here. I can switch it on but it just goes to the grey apple screen with the spinning gear and then does nothing for two minutes then restarts itself and repeats this process. It wont let me start in safe mode and if i use the apple hardware test thing it freezes a few seconds into testing and everything stops working. Does anyone have any ideas other than returning it on how to fix it?
     
  12. valve macrumors newbie

    Joined:
    Feb 13, 2008
    #12
    Binsy,

    Boot your Mac from your Leopard/Install-DVD. From there, choose 'Disk Utility' in the (I believe) Tools-menu, and run 'Repair Permissions' on the internal harddisk. See if that solves your problem.

    Good luck!
     

Share This Page