10.5.3/4 Diablo II & Starcraft Problems - Lets send Feedback!

Discussion in 'Mac and PC Games' started by pinnacleseeker, Jul 2, 2008.

  1. pinnacleseeker macrumors newbie

    Joined:
    Mar 3, 2008
    #1
    Hello Everyone,

    As many of you know there is a problem with the Apple display drivers for systems with NVIDIA and Intel graphics chips. The bug was introduced with the Macbook Pro (Penryn) sytems, and then subsequently with the 10.5.3 update for other systems. The 10.5.4 update has not fixed the problem. The end result is that older applications that rely upon 256 color support will crash (e.g Starcraft and Diablo II).

    I noticed that there is a solution to this bug that involves replacing new kext files with older ones (from an earlier graphic driver update). Although this fix is available - I do not think people should need to rely on techniques like this to get there favorite applications up and running. Apple should really provide an set of updated graphic drivers to fix the bug.

    The major problem when dealing with Apple is getting the information to the right people in the company. There is a post over on the Apple support discussion forums with close to 5,000 views - and yet there is no guarantee that an Apple engineer would see it. There is also a post on the Battle.net forums, but again there is no guarantee that the right person will see it.

    I suggest that we all use the "feedback" feature from the Apple website. This will result in a situation were our problem will become the most visible.

    The URL for sending feedback is:

    http://www.apple.com/feedback/macosx.html

    If you decide to send feeback, please consider posting it in this thread. It would be a great way to keep track of the number of feedback submissions sent regarding this issue.

    I would suggest referring to "older applications" rather that specifically pointing out Starcraft and Diablo II to be taken more seriously - but that is only an opinion.

    Sending feedback took me around 5 minutes.

    Below is what I sent.

    Subject: 10.5.3 & 10.5.4 Display Driver Bug - Lacks 256 Color Support

    Brief Description: NVIDIA graphics drivers lack 256 color support.

    Full Description:

    The NVIDIA graphic drivers that shipped with the Macbook Pro (OS X 10.5.2) were lacking 256 color support, which causes several older applications to stop working. When the 10.5.3 update was released, this problem also began to affect other systems, including those with an Intel-based graphics chip. The problem continues to exist in the 10.5.4 update. Users with systems containing an ATI graphics chip are unaffected by this problem.

    Please fix this graphic driver bug, as many users are complaining about the inability to run certain older applications.

    OS X Version:

    System Version: Mac OS X 10.5.4 (9E17)
    Kernel Version: Darwin 9.4.0

    Hardware Specifications:

    Model Identifier: MacBookPro4,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.4 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 3 MB
    Memory: 4 GB
    Bus Speed: 800 MHz

    Chipset Model: GeForce 8600M GT
    Type: Display
    Bus: PCIe
    PCIe Lane Width: x16
    VRAM (Total): 256 MB
    Vendor: NVIDIA (0x10de)
    Device ID: 0x0407
    Revision ID: 0x00a1
    ROM Revision: 3212


    Thanks to everyone who sends feedback,

    PinnacleSeeker
     
  2. poweredbybacon macrumors newbie

    Joined:
    Jul 2, 2008
  3. Synorax macrumors newbie

    Joined:
    Jul 6, 2008
  4. NerVT0xiN macrumors newbie

    Joined:
    Jul 6, 2008

Share This Page