10.5.3 hosed my 08 Mac Pro

Discussion in 'macOS' started by benpatient, Jun 17, 2008.

  1. benpatient macrumors 68000

    Joined:
    Nov 4, 2003
    #1
    I've been holding off on 10.5.3 because it seemed to be giving people some real troubles and I've had some issues with 10.5 in general and I'm hesitant because of that.

    The Spore Creature Creator demo came out today and wouldn't you know, it requires 10.5.3 for some unexplained reason. So I decided to bite the bullet and take the plunge and all of those wonderful metaphors, because I figure what's the worst that could happen.

    Short answer: complete system meltdown.

    I did the software update install, and when it told me i would have to restart and then logged me out of all apps, it tried to do the update but said that the package checksum was invalid or something like that. it then proceeded to exit the updater and dump me back out to the desktop. I read on here about some issues with 10.5.3's package being corrupt on some of Apple's mirror sites. So I downloaded the combo package from apple.com and ran that. It seemed to work, and then it asked to restart. I said OK and it rebooted...only I never got past a solid blue screen with the spinning black pinwheel in the center of the screen. It sat there for 45 minutes. I went and had dinner and came back and no change. So I turned it off and back on again. Immediate Kernel Panic! Awful. Single user mode doesn't work, either. Same error. Something about the extension archive having a bad checksum. Open up the system DVD and reboot from there. I look at my TM restore points and it shows 1 restore point (the most recent) as being OS 10.5.3 and the rest being from 10.5.2. OK, so it thinks it successfully installed .3 Great.

    So I ran disk utility, which by the way showed no errors on the boot drive less than a week ago when i last ran it to repair permissions. It immediately gets my attention because the boot drive is unmounted, which is weird. My other internal drives are mounted and fine, but the boot drive won't mount.

    I do a verify/repair on it and it fails after saying that the "keys are out of order"

    Funny thing is my work mac pro took the 10.5.3 update and rebooted and never looked back. It was like nothing happened except my uptime reset.

    Now Time Machine is recovering from one of my earlier backups from today. Only 2.5 hours left on that one. If I get up in the morning and I'm still getting kernel panics, I might just have to boot up in XP to get some work done...

    I'm typing this on my trusty 10.4 macbook. Sad that I've resorted to calling this thing "trusty." That's a completely relative term, believe me.
     
  2. HLdan macrumors 603

    HLdan

    Joined:
    Aug 22, 2007
    #2
    No offense, but you can't possibly blame 10.5.3 since it installed just fine on your work computer. That should tell you something, you must have existing software's, haxies or beta software or corrupt files that didn't agree with the new update.
    Also you used the word "meltdown", after reading that you were able to use the install disk and run disk utility and then you mentioned that you could still boot into XP then your meltdown is a bit of an exaggeration. At this point I would suggest an archive and install and the best course of action would be an erase and install to clean out anything corrupt.
    For the record, my iMac 24" has had zero issues since the 10.5.3 update.
     
  3. benpatient thread starter macrumors 68000

    Joined:
    Nov 4, 2003
    #3
    no offense, but if 10.5.2 works without any problems for several months, and then when you install 10.5.3 it tells you that your hard drive catalog tree is so damaged that disk utility can't even finish processing the errors, then the problem is with 10.5.3 in some way or another.

    I don't have "haxies" installed. I have no strange 3rd party apps or system-modifying things. I have Adobe CS3 and various well-known and documented applications.

    The restore from time machine finally finished last night after 4 hours and the machine rebooted into 10.5.2 with zero issues.

    Disk utility reports no errors.

    Now how is that unrelated to 10.5.3, again?

    Funny that the only response i got was someone blaming me. typical. i don't know why i keep coming back here.
     
  4. jwt macrumors 6502

    Joined:
    Mar 28, 2007
    #4
    I had an issue where Safari 3 would unexpectedly quit upon closing any window or tab after the 10.4.11 update. It turned out that the problem was an incompatibility with Speed Download 3, but people refused to believe Apple could have anything to do with my troubles. They even went as far as saying I installed the update wrong. How the F is that possible?! I run the Apple written installer and click restart when finished. Whatever, zeolots.
     

Share This Page