10.5.6 Disables Pwnage Tool

Discussion in 'Jailbreaks and iOS Hacks' started by mrat93, Dec 16, 2008.

  1. Gray-Wolf macrumors 68030


    Apr 19, 2008
    Pandora, Home Tree
    Nice. They get their phones back to the way they intended. People choose to has the phones, Apple as every right to protect the use of the phones. :rolleyes:
  2. mavis macrumors 68040


    Jul 30, 2007
    Tokyo, Japan
    Actually, the 'problem' has already been solved. The iPhone can still enter DFU mode if it is connected to the Mac through a USB hub. ;)
  3. DannyBres macrumors 65816


    Oct 30, 2007
    Dev Team says:-

    "DFU Problems

    Lots of users have been experiencing problems with the use of DFU mode after applying yesterday’s 10.5.6 system update.

    We believe this behavior is due to a kernel bug not a specific countermeasure by Apple. Possible fixes are (try at your own risk!) - "

    and they suggest 3 solutions... like just do it on a pc or use a hub!
  4. hellomoto4 macrumors 6502a


    Jul 11, 2008
    Fix the problem by plugging in your iPhone/iPod touch through a usb hub.
  5. Peterkro macrumors 68020


    Aug 17, 2004
    Communard de Londres
    I guess making a bootable back up before updating to 10.5.6 wasn't just paranoia after all.
  6. macbookhamburg macrumors regular

    Jan 3, 2007
    well they should work more on perfecting the software than on preventing jailbreaks... since there is still so much missing and a lot of the features i would like to have (like a search funktion for mail) are already avialable with jailbreak
    so it doesn´t seem that difficult to add...
    (my phone is not jailbroken at the moment by the way)
  7. daneoni macrumors G4


    Mar 24, 2006
    So does anyone have the 10.5.5 kexts...it seems having to use a USB hub isn't the ideal solution...especially for laptops
  8. TheSpaz macrumors 604


    Jun 20, 2005
    From another thread:

    I just did it... but, I'm not at home to check to see if it worked. (I did it over VNC)
    This should work though.
  9. LSUtigers03 macrumors 68020


    Apr 9, 2008
    You're joking right?
  10. GNice macrumors 6502

    Aug 7, 2007
    How about I BOUGHT the phone I so should be able to use it as I see fit.:rolleyes:
  11. meagain macrumors 68030

    Nov 18, 2006
    TheSpaz - did that work well for you?

    I really want to upgrade my macs. USB "hub"? uhhh...?
  12. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    The point is that there's no indication that either this or the issues caused by the USB kext's on the newest Macbook and MBP were intentional countermeasures against iPhone hacking. With respect to the MB/MBP issue, it affected other devices as well, including Blackberries, and Apple is already making changes/fixes. With respect to 10.5.6, I don't know yet, but given that even the iPhone Dev Team doesn't seem to think this is Apple going after them, why do you think it is?
  13. TheSpaz macrumors 604


    Jun 20, 2005
    Yes it did actually. Those instructions were actually designed for the new MacBooks, but it works for 10.5.6 on other machines as well. Nice.
  14. phas3 macrumors 65816

    Oct 5, 2008
    spaz can you upload the proper kext files somewhere so we can download it i' trying to jailbreak my phone and i dont have a hub and will those kext work on a macbook and a macbookpro?
  15. TheSpaz macrumors 604


    Jun 20, 2005
    Doesn't anyone use Time Machine?
  16. phas3 macrumors 65816

    Oct 5, 2008
    well...no unfortunately not me i dont not have an external hard drive :(
  17. Snide macrumors 6502a


    Apr 12, 2005
    It certainly saved me from the disaster that was 10.2.8...;)
  18. phas3 macrumors 65816

    Oct 5, 2008
  19. TheSpaz macrumors 604


    Jun 20, 2005
    Can't you just download the 10.5.5 Combo Update and extract the files using Pacifist?
  20. phas3 macrumors 65816

    Oct 5, 2008
    can someone tell me if i did this right

    btw spaz i did what you said and i was able to get the kext files

    Rockwell$ sudo -s
    bash-3.2# rm -r /system/library/extensions/iousbfamily.kext
    bash-3.2# mv /users/rockwell/desktop/iousbfamily.kext
    bash-3.2# sudo chmod -R 755 /system/library/extensions/iousbfamily.kext /system/library/extensions/iousbfamily.kext
    bash-3.2# sudo chown -R root:wheel /system/library/extensions/iousbfamily.kext
    bash-3.2# rm /system/library/extensions.mkext
  21. TheSpaz macrumors 604


    Jun 20, 2005
    I think you need to use the same capitalization in your file paths there.

    The first thing I did was replace the plugin files from 10.5.5 into the IOUSBFamily.kext file. Then I made sure the modified IOUSBFamily.kext file was on my desktop. Then I simply followed those commands (making sure the file path names were exact). That's it. Then restart.
  22. phas3 macrumors 65816

    Oct 5, 2008
  23. integragsr macrumors member

    Aug 14, 2008
    Help with iPhone and 10.5.6

    Hi everyone, I need your help with my iphone. I been trying to jailbreak it but unfortunately I can't, I get stuck with a white screen right after I release the home button. I tried using the usb hub and keyboard's USB because I did the mistake to update to the 10.5.6 and now I cant jailbreak my iphone 3G. I want to now if I can go back to the 10.5.5 version, I did a backup using time machine before I updated to 10.5.6. and I want you guys to guide me in how to revert to 10.5.5, I will appreciate any type of help.

    P.S I apologize for my writing and I didn't do the kext solution because I am new with MACS and don't know how to use the terminals.:confused:
    P.S I used quickpwn for the 2.2 jailbreak on osx 3 different times but still get the white screen.

    thanks you guys and Merry Christmas to everyone.
  24. dZp macrumors 6502a


    Mar 29, 2006

Share This Page