10.5.6 update; can't log-in/access my desktop

Discussion in 'macOS' started by vexingv, Dec 15, 2008.

  1. vexingv macrumors newbie

    Joined:
    Dec 15, 2008
    #1
    I'm using a 12" 1.33ghz G4 PB that was previously working fine w/ 10.5.5. This evening, I installed the 10.5.6 update; left Software Updater to download the package (i actually took a 30-minute nap while it downloaded as I have fairly slow DSL connection) and then allowed it to restart the machine to perform the install. I then showered and when I returned the machine had already rebooted and was showing the log-in screen (the log-in box/windows displayed 10.5.6 when I clicked). I entered my password and waited to log-in. However, the Leopard background/splash screen (the space image or whatever it is) remains and a mouse cursor is the only thing visible on-screen.

    I've physically rebooted several times and tried to login to no avail. I pulled out the Leopard install disc to run Disk Utility, repair permissions, and verify the disk. However, I'm still stuck with only the background image showing and no access to my desktop. Interestingly/fortunately, I noticed that I'm able to access the machine's hard drive/files through smb/unc shares on the windows desktop that I'm currently using.

    Any ideas as to what I can do?
     
  2. madog macrumors 65816

    madog

    Joined:
    Nov 25, 2004
    Location:
    Korova Milkbar
    #2
    As with all updates Apple recommends making a backup of your drive just in case something like this goes wrong. Hundreds of thousands of computers updating will have an error or few along the way.

    You already tried the repair, and short of buying and trying out DiskWarrior, then you can always do an Archive and Install.

    While booted to a system disk click continue until it asks you to select a destination for installation, click the options button and select ARCHIVE AND INSTALL and PRESERVE USER DATA AND SETTINGS. This will reinstall the base OS from scratch, setting the old system aside as a Previous System (for your later review and deletion) and preserve your user settings and home folder. Then, you'll have to update the system back up through the Software Updates.
     
  3. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #3
    Ran fsck, repaired permission before the update ... then again after it, along with the update boot cache and ran all the periodic cache cleaning.
     
  4. vexingv thread starter macrumors newbie

    Joined:
    Dec 15, 2008
    #4
    I don't think I'm ready to reinstall OSX just yet. I don't have the time to do it and might not even have the space to archive/install (60 gb drive w/ ~20 gb free). It seems that I still have network access to the hard drive and I can always put the powerbook into target-disk mode, but I'm going to continue working towards accessing the desktop. I can enter my password and log-in but it never progresses past the leopard background. I think in the past this has happened a couple of times after leopard updates, but rebooting usually resolved the issue.
     
  5. vexingv thread starter macrumors newbie

    Joined:
    Dec 15, 2008
    #5
    I'm not sure what you mean by that. I was able to repair permissions and verify the disk through the Leopard install disc only after installing the update and encountering this issue.

    Is there anything else that I might be able to do via bootup options, etc?
     
  6. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #6
    The Install disk repair permissions can have outdated info, which is why running it off the HD is best.

    Repairing the disk and repairing permission before a major update, is just so that a disk or permission error doesn't cause an issue with the OS update.

    However booting into safe mode and repairing the install is also an option. Could be a login item hanging the login.

    Should also be able to use console.app to look at the logs and see what is hanging/crashing the machine. Though a new user created while in safe mode may be a temporary fix.
     
  7. vexingv thread starter macrumors newbie

    Joined:
    Dec 15, 2008
    #7
    hmm...i didn't realize that there is a difference in repairing from the install DVD or from OSX itself as I thought it was simply Disk Utility doing the work regardless of environment. At the time, I couldn't gain access to the desktop, which is why i did it via the DVD. Having already repaired via the install DVD, is there any other way to "correctly" repair permissions if i can't access Disk Utility (I really wished I had enabled SSH as I think I might have been able to launch it from there...)? Currently, I'm in single user mode and running fsck -f from the commandline

    At one point, I was able to gain access to the desktop, which reported an "Unresolved kernal trap." (Not sure what what that error is all about, but I submitted it to Apple). However, nothing was actually running in the desktop environment: ie. I couldn't launch programs, system prefs, or menus. The desktop looked like normal, but nothing could actually be launched.

    At this point, I think my system is likely fubared. Fortunately, i've got other computers to use in the meantime and I try to run everything cross platform. I'm going to backup files via ethernet or target disk mode to my Windows desktop and start a fresh install at the end of the week.
     
  8. QueenZ macrumors 6502

    QueenZ

    Joined:
    Oct 26, 2008
    #8
    Hmm. When i tried to install 10.5.6 update it froze at install.. :( But luckily i got my desktop runnnig.. I still haven't succeeded with that update..
     
  9. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
  10. zed2 macrumors 6502a

    Joined:
    Jul 17, 2004
    Location:
    Bucks
    #10
    Well I updated my laptop no problem PowerBookPro, but my Desktop G5 2.5 is now very broken.. Can just about login but nothing will run..

    Via ssh I was able to view the system.log file and see this:

    Dec 16 13:55:19 holly /System/Library/CoreServices/Dock.app/Contents/MacOS/Dock[124]: LaunchServices/5123589: coreservicesd is running an unsupported version, 0 ( we are 10500000 ), so we cannot talk to it.
    Dec 16 13:55:20: --- last message repeated 3 times ---
    Dec 16 13:55:20 holly WindowServer[79]: LaunchServices/5123589: coreservicesd is running an unsupported version, 0 ( we are 10500000 ), so we cannot talk to it.


    Any ideas other than reinstalling??

    Cheers,
    --Zed
     

Share This Page