10.5.6 Update + iLife 09'

Discussion in 'macOS' started by inhalepower, Jan 28, 2009.

  1. inhalepower macrumors newbie

    Joined:
    Jan 28, 2009
    #1
    Well heres the deal, I just got the new iLife 09' and I want to install it but it requires the updated OS X 10.5.6, which software updater can not locate, i've tried restarting multiple times, and it still cannot find it. I've also downloaded it directly from the apple website(The single Version and the Combo), and it will let me install neither of them. I have verfied my disk permissions, and repaired them with no success in being able to install the new update, so I come to you guys in need of help of how I can correct this problem. Thanks in advance.

    Macbook Pro:
    2 Gb Ram
    2.4 GHz CPU
    250 GB of Memory: Plus you can see how much is used in the image below
    Running the current version of Leopard OS X 10.5.5

    Here is a picture of the error:
    [​IMG]
     
  2. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #2
    What are you running right now? OS-wise?

    And what are your hardware specs?
     
  3. inhalepower thread starter macrumors newbie

    Joined:
    Jan 28, 2009
    #3
    Oh Yea completly forgot about that, sorry.

    Macbook Pro:
    2 Gb Ram
    2.4 GHz CPU
    250 GB of Memory: Plus you can see how much is used in the image
    Running the current version of Leopard OS X 10.5.5
     
  4. nintendude macrumors 6502

    Joined:
    Jan 17, 2008
    Location:
    MD
    #5
    The OP has already tried the downloads from Apple's website
     
  5. arrash macrumors member

    Joined:
    Nov 3, 2006
    Location:
    Marlborough, MA
    #6
    If you just want to be able to install iLife 09, go to /system/library/coreservices and copy systemversion.plist to your desktop. Then open it with textedit and change the two references of 10.5.5 to 10.5.6. Then copy that file from desktop back to the original path above. It will confirm to overwrite, then authenticate. This procedure will fool the iLife to think to have 10.5.6!
     
  6. inhalepower thread starter macrumors newbie

    Joined:
    Jan 28, 2009
  7. inhalepower thread starter macrumors newbie

    Joined:
    Jan 28, 2009
    #8
    WOW! nice dude, it works, can i change the things back now to 5.5 or will iLife not work if i do that?
     
  8. SnowLeopard2008 macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley
  9. TwinCities Dan macrumors 603

    TwinCities Dan

    Joined:
    May 19, 2008
    Location:
    Double Parked out front of the Courthouse
    #10
    Dito, why can't you just update instead of this voodooo? :confused:
     
  10. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #11
    Repeating the OP's question doesn't really help :)
     
  11. sickmacdoc macrumors 68020

    sickmacdoc

    Joined:
    Jun 14, 2008
    Location:
    New Hampshire
    #12
    I don't know about changing it back to 10.5.5 but do keep in mind that that trick was just to allow the install. If the iLIfe programs make any calls to specific 10.5.6 additions (as it would seem like they would or they would only require 10.5.5 in the first place) it will be crash city.

    Tricking an installer is one thing- successfully running the software is another matter. ;)
     
  12. TwinCities Dan macrumors 603

    TwinCities Dan

    Joined:
    May 19, 2008
    Location:
    Double Parked out front of the Courthouse
    #13
    :eek:, I got sidetracked, sorry.

    Even with the direct links provided above? :confused:

    Odd....
     
  13. inhalepower thread starter macrumors newbie

    Joined:
    Jan 28, 2009
    #14
    ^ You didn't read my entire post then ^ to lazy to quote btw
     
  14. arrash macrumors member

    Joined:
    Nov 3, 2006
    Location:
    Marlborough, MA
    #15
    Great point about the application stability due to lack of the additions in 10.5.6
    I have been using it extensively since I got to two days ago. I have used iPhoto, GarageBand, iMovie and all their newfeatures and functions. So far, it has been flawless.... Not a single crash! I have logged about 12 in depth hours of usage with iLife 09 and tested all the new bells and whistles.

    I feel there is some unrelated reason apple wants everyone on 10.5.6. What better way for them to convince you than to make a highly anticipated suite of programs force it on you.
     
  15. adrianjt macrumors newbie

    Joined:
    Jan 1, 2005
    #16
    corporate conspiracy theories are great.

    thanks all, now i still dont have to upgrade to x56

    iwork appears stable
     
  16. jkwasy macrumors newbie

    Joined:
    Feb 23, 2010
    #17
    would this technique work for 10.5.8 to 10.6?? i would like to get feedback before i attempt it incase it doesn't apply to this particular update
     

Share This Page