10.5.7 Broke my mouse

Discussion in 'MacBook' started by buddhistgrandma, May 18, 2009.

  1. buddhistgrandma macrumors newbie

    Joined:
    Jul 22, 2008
    #1
    This morning, before I updated to 10.5.7, my mouse was working fine. Then I installed the update, and it has not been working real well since. The mouse only actually works every 5 or 6 clicks. It wont select things until I spam click it. I tried the mouse on my other computer, and the mouse works fine there. Has anyone else seen this issue?

    I'm running a Macbook, and my mouse is a Microsoft Wireless Laser Mouse 5000.

    Thanks.
     
  2. SHIFTLife macrumors 6502

    Joined:
    Jul 24, 2008
    #2
    Is this a Bluetooth mouse, or does it have a separate RF receiver plug? If it's bluetooth, you might try unpairing it (delete the entry in the Bluetooth manager), and then try to pair it again.
     
  3. okrelayer macrumors 6502a

    Joined:
    May 25, 2008
    #3
    If it means anything my blue tooth mighty mouse has been acting up since the update
     
  4. buddhistgrandma thread starter macrumors newbie

    Joined:
    Jul 22, 2008
    #4
    Its not bluetooth. Its has a RF USB receiver component to it.
     
  5. kraftzwerg macrumors regular

    Joined:
    Jul 8, 2005
    #5
    Mine as well! It simply stops working all of a sudden and I need to use a wired mouse to click the bluetooth icon and choose "disconnect" and then again "connect" to the mighty mouse. Then it works fine ... for a day or so.
     
  6. sporadicMotion macrumors 65816

    sporadicMotion

    Joined:
    Oct 18, 2008
    Location:
    Your girlfriends place
    #6
    Same here. I re-paired the connection and it was fine for half a day but then it was time to go to work so I won't have a chance to see if the problem is permanently solved until I get back home on Wednesday.

    Have you tried re-pairing the connection?
     
  7. testcard macrumors 68030

    testcard

    Joined:
    Apr 13, 2009
    Location:
    Middle England
    #7
    Mine was randomly losing its Bluetooth connection before the update and it's still doing it. Others on the forum have posted similar experiences.
     

Share This Page