10.5.7: trackpad and keyboard stops working

Discussion in 'macOS' started by zacman, May 14, 2009.

  1. zacman macrumors 6502a

    Joined:
    Jul 11, 2008
    #1
    I have some strange problem after updating my MacBookPro4,1 to 10.5.7. After a while (can be a few hours) the trackpad and keyboard stop working. When I then put the MBP to sleep and wake it up, both work again but only for about maybe 5-10 minutes. This can be reproduced (put to sleep, works for 5min, put to sleep, works for 5min, etc.) When I reboot it works again for some hours.

    Anyone else having similar problems?
     
  2. Palmbiki macrumors newbie

    Joined:
    Nov 21, 2008
    Location:
    Chicago, IL
    #2
    Hi!

    I am having a similar issue after updating to 10.5.7 with a unibody MacBook:

    The update went smoothly until the restart, when the log in screen came up, and my track pad and keyboard will not work. I tried restarting, with a USB mouse attached, no luck. I reset the PRAM with no results. I tried to repair permissions with the Leopard Install disc, nothing changed.

    Any suggestions?
     
  3. Palmbiki macrumors newbie

    Joined:
    Nov 21, 2008
    Location:
    Chicago, IL
    #3
  4. jmccullough108 macrumors 6502a

    jmccullough108

    Joined:
    Nov 2, 2008
    Location:
    St. Louis, MO
    #4
    You need to archive and install, your usb drivers are corrupted.
     
  5. berto macrumors newbie

    Joined:
    Mar 28, 2008
    #5
    I just ran into this. Checked my email at home, all was good. Put the machine to sleep, tossed the macbook pro in my bag and went to work. When I got to work, kb and trackpad were not working.

    I removed the battery, disconnected it from wall power and held the power button down for 5 seconds to reset the PRAM. Put the battery back in, no love, still broken.

    I then removed the battery, cleared the PRAM again, and plugged in external power (without the battery). That worked!

    While I was logged in, I noticed I was really close to filling up my drive. I cleared some stuff and got 5.6G free. When I put the battery back in and power cycled, it continued working. I'm not convinced the disk space had anything to do with it, but it's the only thing I changed.

    I'm going to try another power cycle to see if it continues to work. If I don't repost, no news is good news.
     
  6. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #6
    berto: that reset is for the System Management Chip or SMC. A PRAM reset would have required you to hold down option+:apple:+P+R on boot until it chimes 2-3 times.

    Don't have anything to offer as to the main thrust of the thread however, sorry.
     
  7. ahocker macrumors newbie

    Joined:
    May 24, 2009
    #7
    I am having a similar problem as well on my MacbookPro4,1 with 10.5.7. The trackpad and keyboard work for many hours and then stop. The caps lock key doesn't even respond at this point, i.e. the led doesn't light up when pressed. Not sure if the led lighting up is established on the hardware side or through some sort of interrupt on the software side. I also have a usb mouse plugged in which works fine, even after the keyboard and trackpad have stopped. I have tried reinserting the usb mouse multiple times when the keyboard has stopped and only the usb mouse is working. If I reboot everything works fine for hours. (haven't tried sleep mode yet, and I am removing the usb mouse to see if the problem still arises) Never saw the problem in 10.5.6.
     
  8. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #8
    Wow. This is the first I've heard of this issue. I hope its a rare problem.
    No problem here (unibody MacBook). Wonder if its only the MBPs?
     
  9. metfan884 macrumors newbie

    Joined:
    May 25, 2009
    #9
    Macbook Unibody

    I am having the same problem with the Unibody Macbook (it is not the pro), I installed 10.5.7 and put my computer to sleep after. When I turned it back on in the morning, the keyboard and mouse would not work, neither would the usb ports. Even if i shut it down and start it back up it still will not work. How do i reinstall Leopard without the keyboard or mouse working?
     
  10. metfan884 macrumors newbie

    Joined:
    May 25, 2009
    #10
    Working, but had to erase harddrive

    i put the leopard disk in and held down c during restart. I had to erase my harddrive though because, i had a newer version of leopard installed, (10.5.7) the disk came with 10.5.6.:)
     

Share This Page