10.5 iCal Disappeared (Sortof)

Discussion in 'Mac Basics and Help' started by cppnerd, Jun 5, 2008.

  1. cppnerd macrumors newbie

    Joined:
    Jan 19, 2007
    #1
    Hi - I seem to have encountered the most bizarre problem today. Wondering if anyone has had this happen and if there is any easy way to restore it?

    I clicked on iCal (which I had been using throughout the day) and got an error saying the architecture was not supported on my computer. My dock icon still showed the correct date. Relaunching the dock changed the icon to the unsupported icon.

    So I ran file /Applications/iCal.app/Contents/MacOS/iCal out of curiosity and got No such file or directory. Turns out, the iCal bundle doesn't have the MacOS folder. Resources is there but that's it.

    Here's where it gets even stranger. A quick ls shows last modification date a few days ago at the time I ran the 10,5,3 update. So obviously, some time since then the MacOS folder got deleted, but there is no change to the timestamp on the application folder (iCal.app) or even the Contents folder.

    I've used iCal for several days without any problems since that update until just today.

    As a heads up, I have no 3rd party modifications to the system or anything. It's a stock MBP with mostly just Apple's apps and a few other mainstream commercial apps (again, no strange settings). The computer hasn't had -any- problems either with any apps (iCal included) crashing or acting strange.

    So I don't really care if my calendar data is lost; it's all backed up just fine, I just want to get the application back. Any ideas there and -any- thoughts as to how a bundle changed with no notice or timestamp changes? :confused:
     
  2. varmit macrumors 68000

    varmit

    Joined:
    Aug 5, 2003
    #2
  3. cppnerd thread starter macrumors newbie

    Joined:
    Jan 19, 2007
    #3
    OK, I installed the combo update and it almost fixed the problem. iCal now shows the transparent text (JUN 5) on the Dock with no red & white background. It bounces and then does nothing.

    The app bundle appears to have been somewhat restored...
    The binary is back, but running the binary manually from terminal gives:

    Code:
    scott-mbp:MacOS scott$ ./ical
    2008-06-05 17:55:57.999 ical[263:10b] Unable to load nib file: MainMenu, exiting
    
    The English.lproj has the following nib files in it:
    Code:
    AlarmInstance.nib	Localizable.strings	Publish.nib
    DialogStrings.strings	PreferencesPanel.nib	Subscribe.nib
    InlineInspector.strings	PubSub.strings		UndoStrings.strings
    InspectorViews.nib	PubSubErrors.strings
    So could someone check if I'm only missing MainMenu.nib or others too? Would these be accessible from my OS X disc (I don't have it with me currently)?
     
  4. varmit macrumors 68000

    varmit

    Joined:
    Aug 5, 2003
    #4
    Are you on a mac that is Intel or PPC based. Maybe someone can zip up iCal and send it to you since it seems that its things missing from inside the iCal package. I'm PPC based mac.
     
  5. cppnerd thread starter macrumors newbie

    Joined:
    Jan 19, 2007
    #5
    I was able to get the iCal.app from another 10,5,3 Mac and replace the missing files and everything is back and working again. Copying iCal from the leopard CD and then running the combo update didn't fix it, I just needed to apparently replace the folder.

    So on my other question... has anyone had something similar happen or anyone know how this may have happened? I've worked extensively on Linux machines for years (and some Macs too) and have never seen part of a folder disappear for no apparent reason and leave no record in a timestamp even. :confused:
     
  6. divinenephron macrumors newbie

    Joined:
    Aug 17, 2008
    #6
    More disappearances

    I'm currently on 10.5.4, and I have iCal exhibiting the same ghost number behaviour in the dock, I haven't just updated or anything to that effect, so I'm not sure why it is doing this.
    After checking, I do appear to have the MainMenu.nib file, and both the app and the dock icon behave if I launch iCal.
    Moving iCal to the root application folder does not work either.
     
  7. fringe1470 macrumors newbie

    Joined:
    Aug 10, 2010
    #7
    same problem, please help

    Hi, this exact problem just appeared in my computer and it also happened after I installed updates on the computer. Could someone please explain how I can fix this? Thanks.
     
  8. broda macrumors newbie

    Joined:
    Aug 27, 2014
    #8
    Fixed

    If you're using cleanmymac, this is the reason for the launch failure in several apps. It deletes several files that it's not supposed to. I went into the package contents of the Calendar app, looked into the resources, and realized that inside the English.lproj the mentioned file is missing (mainmenu.nib). I found the file in the folders for different languages. All I did was copy/paste the file from the other language folders into the ones I use regularly and the app hasn't given me any issues since.

    Hope this helps
     

Share This Page