10.6.2 and audio out... Changed to internal speakers

Discussion in 'Mac Pro' started by Lumpydog, Nov 10, 2009.

  1. Lumpydog macrumors 6502

    Joined:
    Aug 3, 2007
    #1
    This is the second time an update has done this to me (Early 2008 Mac Pro).

    Run the update - reboot - "sound effects" and "output" changed from "line out" to "internal speakers".

    What's up with that? Not a big deal - but kind of a pita when I get a call at work from a family member asking why iTunes is playing from the internal speaker...
     
  2. alam macrumors regular

    alam

    Joined:
    Mar 16, 2008
    Location:
    Saudi Arabia
    #2
    im haveing the same issue with my 2008 mac pro, i set my audio output to digital out and every time i reboot it sets it to line out by it self, and my digital out is my default audio output :confused:
    also same issue for audio in when i set it to my blue mic input it sets it automatically to line in after a reboot :confused:
     
  3. Lumpydog thread starter macrumors 6502

    Joined:
    Aug 3, 2007
    #3
    For me it's temporary - only happens after some (2 so far) OS point updates complete. Once I go into the audio settings and set the outputs back to line out - no more problems after that.
     
  4. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #4
    This happened to me too. However, I cannot get my iChat sounds to come out my line out no matter what I try. All other sounds come out my line out except for iChat. Anyone else have this problem? It's driving me nuts!
     
  5. akadmon macrumors 68010

    Joined:
    Aug 30, 2006
    Location:
    New England
    #5
    Same thing here. I don't have elderly relatives with Mac Pros, so not a big issue for me :)
     
  6. Msbeezy macrumors member

    Joined:
    Sep 20, 2009
    #6
    Same thing here..I had to re-set audio output ...?
     
  7. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #7
    If you're having trouble with Sound Effects or iChat, check this out.

    I found this in another thread and I thought I'd share. Thank you Southerndoc!
     
  8. kaks macrumors member

    Joined:
    Feb 26, 2008
    #8
    same problem.

    Even when i switch the output, half the sounds come through the internal speakers still.
     
  9. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #9
    Check what source your sound effects are set to. See the post directly above yours. You can't just change the output, you also have to change the sound effects output too.
     
  10. angemon89 macrumors 68000

    angemon89

    Joined:
    Feb 5, 2008
    Location:
    The place where Apple designs stuff
    #10
    Had the same problem(on my iMac). Annoying but whatever.

    I'm sure the genius bars will be full today because of this.
     
  11. mac666er macrumors regular

    Joined:
    Feb 7, 2008
    Location:
    San Francisco, CA
    #11
    I have an early 2007 Mac Pro and have this same issue even after restarting a couple of times (sound always reverts to internal speakers from digital out).

    Seems to me that preferences of the sound control panel are being played around with or something changes them on start-up.
     
  12. maghemi macrumors 6502

    Joined:
    Aug 7, 2009
    Location:
    Melbourne Australia
    #12
    I had the same problem too. Took me a little while to figure out which settings to change back. But it's all good now.

    Still a little irritating that they keep doing this. As has been mentioned it's not the first time.
     
  13. dgdosen macrumors 65816

    dgdosen

    Joined:
    Dec 13, 2003
    Location:
    Seattle
    #13
    I have an issue where the only sound that works is the internal speaker. I have external speakers hooked up via line out but if I switch to them, I still don't hear anything...
     
  14. Zerozal macrumors 6502

    Joined:
    Apr 3, 2009
    Location:
    PA
    #14
    Yup, after the 10.6.2 update the sound on my MP was changed to "Display Audio". Had to go to the sound preferences and change it back to "Line Out". Oh well--all is well now.
     
  15. maghemi macrumors 6502

    Joined:
    Aug 7, 2009
    Location:
    Melbourne Australia
    #15
    I wonder why apple do this with their updates. It's most irritating.
     
  16. akadmon macrumors 68010

    Joined:
    Aug 30, 2006
    Location:
    New England
    #16
    I supposed it's part of their QC routine (testing only with Apple components), and whoever is the last guy that touches the code keeps forgetting to "reset the switch".
     
  17. Maxian macrumors newbie

    Maxian

    Joined:
    Jul 28, 2008
    Location:
    Italy
    #17
    Got the same exact problme on a 3.1 Mac Pro......i changed the settings and it all worked fine again tho every time i reboot or the MAc goes to sleep it reverts back to the bloody internal speaker......:confused:
     
  18. mac666er macrumors regular

    Joined:
    Feb 7, 2008
    Location:
    San Francisco, CA
    #18
    Today I also found out that if you log out and log back in, the same problem occurs, sound is reverted to internal speakers...

    So this is not related to restarting at all... (or booting/rebooting)
     
  19. KeriJane macrumors 6502a

    KeriJane

    Joined:
    Sep 26, 2009
    Location:
    ЧИКАГО!
    #19
    I noticed this too.

    After updating to 10.6.2 the internal speaker got un-muted on my Mac Pro 1.1.

    However, my particular machine does have a fussy rear audio jack sensing switch that makes having sound in Windows under Boot Camp kinda tricky.

    In Mac OS, you can mute the internal speaker and the sound gets directed to the rear jack (even if no speaker plug is detected) and all is good.

    In Windows (under Boot Camp) if no speaker plug is detected, you get no sound at all from the rear output regardless of what you do with the internal speaker.

    In Windows, the only solution for my machine is to move the speaker plug to one side and that gets the speakers going. (see drawing)

    I'm curious to see if anyone else has this particular issue.

    Have Fun,
    Keri
     

    Attached Files:

  20. mac666er macrumors regular

    Joined:
    Feb 7, 2008
    Location:
    San Francisco, CA
    #20
    I found a fix from the Apple Support forums. I had to do two steps:

    1. Deleted the files on: /Library/Preferences/Audio
    2. Zapped the parameter RAM (PRAM)

    After this, my MacPro reverted to original settings and no longer exhibits that behavior.

    Worth giving it a try!
     
  21. lemonade-maker macrumors 6502

    lemonade-maker

    Joined:
    Jun 20, 2009
    #21
    Didn't work for me. I also removed /Library/Preferences/com.apple.soundpref to no avail. Pretty lame bug.
     
  22. Inconsequential macrumors 68000

    Joined:
    Sep 12, 2007
    #22
    My bug is that when you wake from sleep the sound controls on the keyboard/thing at the top with sound makes the pop come from the internal speaker and only adjusts THAT sound.

    Means i have to go into Sound preferences and select the speakers before everything reverts.

    Annoying or what!
     
  23. mauikekai macrumors newbie

    Joined:
    Nov 13, 2009
    #23
    I have tried all these options to no avail. I have even spoken to mApple and they seem to have no idea this problem even exists!

    Originally Posted by mac666er
    I found a fix from the Apple Support forums. I had to do two steps:

    what support forum and what thread?

    Anybody have anything?

    Thanks for your help in advance
     
  24. Jarman74 macrumors regular

    Jarman74

    Joined:
    Mar 22, 2009
    #24
    I think he's referring to this thread.
     
  25. mauikekai macrumors newbie

    Joined:
    Nov 13, 2009
    #25
    Here is a good solution found on apple discussion forum!

    I finally found the root cause of my problems for this. The problem for me is with file permissions on the 2 Audio plist files. For some reason during the 10.5.6 upgrade they are not set properly. Looking at the all the answers on the forum that seemed worked for one reason or another confirm they are related to file permissions.

    I also have a permanent, reasonably easy fix for it. To fix the permission problem, you need to change the ownership of the files as described below.

    ========================
    Launch Terminal from Utilities folder. This automatically logs you in as yourself.

    To change file ownership, your need to switch login as root. Follow the commands in bold. I left the detailed listing so you can see what to expect. You can copy and paste the bold text into Terminal as they are to save retyping.

    Note the ownership change from "jdoe" to "_coreaudiod"

    unix$ sudo -i
    password: type your normal user password here

    unix# cd /Library/Preferences/Audio
    unix# ls -l
    -rw-r--r-- 1 jdoe admin 3149 11 Nov 22:17 com.apple.audio.DeviceSettings.plist
    -rw-r--r-- 1 jdoe admin 1363 11 Nov 13:06 com.apple.audio.SystemSettings.plist

    unix# chown _coreaudiod com.apple.audio.DeviceSettings.plist

    unix# chown _coreaudiod com.apple.audio.SystemSettings.plist

    unix# ls -l
    -rw-r--r-- 1 _coreaudiod admin 3149 11 Nov 22:17 com.apple.audio.DeviceSettings.plist
    -rw-r--r-- 1 _coreaudiod admin 1363 11 Nov 13:06 com.apple.audio.SystemSettings.plist

    unix# exit

    quit Terminal
    =============================================
    all the commands without the surrounding text for easy copy & paste

    sudo -i
    cd /Library/Preferences/Audio
    ls -l
    chown _coreaudiod com.apple.audio.DeviceSettings.plist
    chown _coreaudiod com.apple.audio.SystemSettings.plist
    ls -l
    exit
    =============================================

    change your Sound Output setting
    see if the timestamp changes on: com.apple.audio.SystemSettings.plist
    the other plist will change after restart
    restart your Mac and see if it works

    good luck!

    If this fails for some reason, I have another way of changing the setting that works but is not preferred. You can edit the plist directly to change the Sound Output but it is harder to do and does not sync with System Preference changes.

    Try it!
     

Share This Page