10.6.2 / Dock icons disappearing and moving **VIDEO ENCLOSED **

Discussion in 'macOS' started by byke, Jan 30, 2010.

  1. byke macrumors 6502a

    byke

    Joined:
    Mar 29, 2007
    Location:
    LDN. UK
    #1
    Dear fellow mac users,
    I have been trying to figure out why my MBA seems to be so odd?

    I am running 10.6.2 OSX and every time I try to move the icons around in the dock they either move place by themselves or delete themselves?

    This is especially true with browser icons.
    For example I could have safari open and try to move the icon in the dock from the far right towards the left ..... It will do this and stay there for approx. 5 seconds and then return back to the far right.?

    If I close the safari program the icon disappears from the dock.
    If I then try to drag the safari program into the dock from the applications folder, it will sit there for 5 seconds again and then just delete itself off the dock. This also happens to Skype, Firefox etc.....

    I have tried everything from terminal / killall Dock ..... to deleting files from /Users/~/Library/Preferences/com.apple.dock.plist etc with nothing working ??

    Does anyone have any idea regarding this as I have tried everything.

    // ps I do have a mobileme account with syncing function but have dock syncing turned off etc .... I have also tried re-booting multiple times after trying different routes and nothing has worked.

    Cheers

    After trying nearly everything I can think of (even checking repairing in disk utility) I seem to have drawn a blank.

    So I have enclosed a video of my desktop showing the problem of the disappearing icons. The weirdest part is its selective so some icons could stay when being dragged their while other disappear in a matter of seconds?


    http://vimeo.com/9098631
     
  2. greg400 macrumors 6502

    Joined:
    Aug 13, 2009
    #2
    Go to Disk Utility and repair the permissions on your hard drive then restart your computer. If that doesn't fix anything, then go into Console and post what it's doing.
     
  3. byke thread starter macrumors 6502a

    byke

    Joined:
    Mar 29, 2007
    Location:
    LDN. UK
    #4
  4. byke thread starter macrumors 6502a

    byke

    Joined:
    Mar 29, 2007
    Location:
    LDN. UK
    #5

    I tried repair, unfortunately nothing.
    enclosed is a screen shot of the consul showing errors with the sync.

    So far I have tried unregistering this from sync etc but no luck.
     

    Attached Files:

  5. Cenobite macrumors newbie

    Joined:
    Sep 8, 2009
    Location:
    Germany
    #6
    MobileMe does not sync its data directly from Dock.app but from your (local) SyncServer. The order of syncing is Dock.app -> SyncServer -> MobileMe. According to your logs your sync already fails at Dock.app -> SyncServer. Therefore turning off syncing in MobileMe does not have any effect on your problem.
    Try resetting your local sync database as described here: http://support.apple.com/kb/TS1627
     
  6. lpfuria macrumors newbie

    Joined:
    Aug 30, 2010
    #7
    Hi!

    Sorry whether comment in a old topic…

    Anyway, as nobody answered before, may I say I had the same issue as described here. And firstly I did as well the same things as byke (deleted the preferences list etc).

    Surprisingly the easy solution given by Cenobite worked very well!

    Thanks Cenobite!
     
  7. dipkat macrumors newbie

    Joined:
    Sep 1, 2010
    Location:
    0, Infinite Loop
    #8
    After nothing else worked, Reset Sync Data in MobileMe pref pane solved the problem for me as well. Thanks everybody.
     

Share This Page