10.6.3 Installation Unmount New HDD Issue

Discussion in 'macOS' started by jln1, Jun 24, 2011.

  1. jln1, Jun 24, 2011
    Last edited: Jun 24, 2011

    jln1 macrumors newbie

    Joined:
    Jun 24, 2011
    #1
    Due to a HDD failure, I recently replaced my Macbook Pro's 250gb HDD with a 500gb WD Caviar Blue, reformatting it into Mac OS Extended (Journal). Today, when I tried to reinstall/TM Snow Leopard, I found I couldn't. Installation always fails at the beginning since the target drive won't unmount. I've spent the entire day searching the web and trying out solutions, to no avail. I'm hoping someone can help me along from the results I've collected:

    Right now, I can't do anything with the HD. Since it won't unmount, I can't erase, restore, repartition, or resize it. Whether I'm accessing it via Disk Utility from my installation disc or from my external HD doesn't matter.

    I've noticed I can force eject the HD in Finder (and in Terminal when on my external HD; sudo won't work from the installation disc), although doing this in Finder sometimes freezes Disk Utility. When force ejected, trying to erase, repartition, or resize will result in various errors after some progress.
    - Erasing: Volume erase failed with the error: File system formatter failed
    - Resizing just gives me: This volume can't be resized
    - I think repartitioning gives a similar error message as resizing; can't test right now since DU isn't responding from yet another force-ejection attempt. I've received a "posix reports: operation could not be completed. cannot allocate memory" error before though I'm not sure it was due to repartitioning

    I've tried installing and backing 10.6.3 onto a second external partition to TM it into the internal drive, to no avail. Cloning doesn't work either.

    I've tried booting the laptop from the external before and after removing the drive, but it still doesn't unmount.

    I can't recall what else I've tried. Little tricks with terminal and disk utility that haven't worked. At this point I'm pretty tired about it all. OS installation onto a brand new, just-reformatted hard drive shouldn't be this hard. It might be the new HDD that's DOA (came in the same package as my sister's new 1TB iMac HDD from OWC, packed well and her HDD's fine) or something's wrong with Disk Utility as people have mentioned before. Hopefully someone can make sense of what I've done so far and suggest a possible solution that I've missed. Working off my external can only be a temporary alternative.
     
  2. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #2
    Boot from a OS X installation DVD, go in to Disk Utility and see if it lets you erase/repartition the drive from there.

    If it can't, it's likely the disk is either jumpered wrong or the disk is bad.
     
  3. jln1 thread starter macrumors newbie

    Joined:
    Jun 24, 2011
    #3
    Then it's likely that the HDD is jumpered wrong/bad. You were talking about the HDD, right? My old Macbook Pro disc went kaput a while ago and I upgraded to SL, which I've been trying to use right now. As I mentioned earlier, Disk Utility on the SL disc doesn't work. Your suggestion reminded me that I could also try using Disk Utility from my sister's iMac disc too; won't install Mac OSX, but I can back up from Time Machine at least. Well, I tried it, and doesn't work. Doesn't unmount either. So it's probably not the installation disc.
     

Share This Page