10.6.3 missing/"losing" mouse click; Problem with USB Overdrive?

Discussion in 'Mac Apps and Mac App Store' started by gumbyx84, Jun 17, 2010.

  1. gumbyx84 macrumors 6502


    Dec 7, 2008
    I don't know where else to post this, so I am posting it here.

    I have recently been having problems with left and middle clicks not being picked up by OS X. For example, I click a link, but its not selected at all. Another is I middle-click a tab in FF to close it, and nothing happens. I usually have to click twice in succession or hold the button down for a second or teo for the click to register. The weirder part is that it doesn't always happen. The right button and back/forward buttons on my mouse don't seem to be affected.

    I've tried to clean my mouse (Logitech MX518) but that doesn't fix the problem. The only thing I can think that is causing the problem is mouse drive I am using (USB Overdrive). I have to use it as Logitech hasn't and won't release drivers for the MX518 for the Mac. A bit of research shows that a few people have had similar issues.

    Has anyone here run into this problem before? Know of a solution? If not, do you guys know of any alternatives to USB Overdrive that I can use that works with 10.6.x?
  2. barrettj macrumors newbie

    Jul 30, 2010
    I am having this same problem. The odd thing is that it started rather recently (as in I've had USB Overdrive installed for a while and didn't experience this). I can't recall having done any updates when it started, it just started out of the blue.

    Did you ever find a solution?

    Edit: I should add that I'm using a Microsoft Mouse, not logitech. And that the problem never seems to occur with right click, just middle and left. Sometimes it registers the mouse down, but never registers the up event (so if I'm selecting text it never finishes selecting until I click again). Uninstalling and reinstalling had no effect.

    Edit #2: Do you use grooveshark? I had the helper application installed and quitting it seems to have caused me to not experience this problem for the past hour or so (previously it happened almost all the time).
  3. gumbyx84 thread starter macrumors 6502


    Dec 7, 2008
    I haven't been having as many problems as I did before, but it still happens. It might have been caused by a failing HD or corrupted partition as my MBP refuses to boot right now. Won't get into it here, but I had a fair amount of "other" issues before it stopped booting, so I think that might be the problem.

    Cool that you seemed to have fixed it on your system. I'm hoping a clean install (after a number of hours backing stuff up) will fix mine. Here's hoping the drive isn't failing as I don't really want to go through all this (backing up, fresh install, putting stuff back) just to have more issues down the line.
  4. helloalien macrumors newbie

    Aug 9, 2011
    Same problem w/ Logitech, but NOT using USB Overdrive

    Hi all,

    I'm having the same problem of missed left clicks with Logitech wireless mice, but NOT using USB Overdrive. I got here by Googling the general problem of missed clicks on Logitech wireless mice.

    By the way, I'm using a unibody MacBook Pro, OS version 10.6.8.

    I've had this issue with multiple Logitech mice recently (tested with 3 of them). I thought it was the mouse hardware at first, but now I suspect software, since:
    • The right click always registers (on all mice).
    • Missed clicks don't seem to correlate with hardness or length of press on left mouse button.

    Anyway, I suspect that it might be a general issue of turning off other software that might be intercepting clicks. I've been using BetterTouchTool, which is a nice application overall. I'm going to try disabling it. Will let you know if it helps. Perhaps USB Overdrive is similarly problematic, if this is the case.

    Also, I'll mention that I've had the same symptoms before and after installing Logitech Control Center in System Prefs.

    TL;DR: Same problems NOT using USB Overdrive. I think it's a software problem. Going to try turning off mouse-related 3rd party software.
  5. helloalien macrumors newbie

    Aug 9, 2011
    Update: Quitting BetterTouchTool solved it for me

    A quick update: Quitting BetterTouchTool, a 3rd-party trackpad enhancement application, has fixed the click-skipping problem for me.

    That leads me to believe that the problem is a software conflict with 3rd party software, which for you guys could be USB Overdrive.

  6. erik0123 macrumors newbie

    Nov 25, 2009
    Solved for me by quitting MagicPrefs

    I was also having the problem with non-Apple mice; randomly skipped many left clicks, and happened with multiple mice that were fine on other computers. The issue went away when I quit MagicPrefs, a 3rd party application for enhancing mouse, trackpad, and keyboard shortcuts.

Share This Page