10.6.3 trackpad & Keyboard Hanging

surferfromuk

macrumors 65816
Original poster
Feb 1, 2007
1,154
0
Since installing 10.6.3 my trackpad (i.e mouse pointer) and keyboard are hanging up for 10 seconds at a time every couple of minutes.

It's seriously annoying - this happening to anyone else?
 

Vonswanko

macrumors regular
Oct 18, 2008
193
0
Same has been happening to me. 2009 13in MBP I have run Onyx, and repaired permissions. Still the same. Very intermittent, and very annoying.
 

surferfromuk

macrumors 65816
Original poster
Feb 1, 2007
1,154
0
Same has been happening to me. 2009 13in MBP I have run Onyx, and repaired permissions. Still the same. Very intermittent, and very annoying.
If it helps I just binned all the PACE support stuff and I haven't had it since.

Strike that - it's still happening.
 

macjonnny

macrumors newbie
Mar 30, 2010
2
0
Same thing happening to me too. MBP late 2008. Unresponsive keyboard and trackpad for 10-15 secs or so. Have never had this problem before 10.6.3. I have tried resetting PRAM and that didn't help. I just reset my SMC, so we'll see if that holds.

I was working most of the day just fine with an external keyboard and mouse. Then as soon as I started using it at home, consistent lockups. Amazingly, it hasn't done it all since I started typing this, so maybe it was the SMC.

Nope, just happened as I typed that last line. If anyone has any other suggestions, please reply.
 

benthewraith

macrumors 68040
May 27, 2006
3,073
80
Miami, FL
Same thing happening to me too. MBP late 2008. Unresponsive keyboard and trackpad for 10-15 secs or so. Have never had this problem before 10.6.3. I have tried resetting PRAM and that didn't help. I just reset my SMC, so we'll see if that holds.

I was working most of the day just fine with an external keyboard and mouse. Then as soon as I started using it at home, consistent lockups. Amazingly, it hasn't done it all since I started typing this, so maybe it was the SMC.

Nope, just happened as I typed that last line. If anyone has any other suggestions, please reply.
I have this problem. It mostly only happens when the computer is left to sit idle for awhile. Then the bug resolves itself. Still quite annoying. This happened only once under 10.6.2. Needless to say, I have an appointment with the Genius Bar tomorrow for two unrelated issues, and will bring the issue up with them tomorrow.
 

cleric

macrumors 6502a
Jun 7, 2008
533
0
Having this issue on my early 09' mini started immedately after upgrading to 10.6.3
 

Signal-11

macrumors 65816
Mar 23, 2008
1,475
2
2nd Star to the Right
Been happening since I updated to 10.6.3 on an early 2008 MBP. Just the trackpad. Keyboard responds fine. Seems completely random and i can't find the trigger. Driving me nuts.
 

mac donalds

macrumors newbie
Mar 18, 2010
5
0
Since installing 10.6.3 my trackpad (i.e mouse pointer) and keyboard are hanging up for 10 seconds at a time every couple of minutes.

It's seriously annoying - this happening to anyone else?

I´m having exactly the same problems with my late 2008 MB Pro.
The Trackpad seems to "freeze" for 5-10 seconds.! It happens randomly, sometimes 1 times per hour, somethimes 2 times per minute :mad: .

It happend the first time only minutes after the update to 10.6.3 :mad:

... the mouse isn`t affected so far ...

apple needs to patch that ASAP


I found another thread about this problem:

http://discussions.apple.com/thread.jspa?threadID=2382651&start=0&tstart=0
 

Signal-11

macrumors 65816
Mar 23, 2008
1,475
2
2nd Star to the Right

Beaverfish

macrumors regular
Dec 15, 2008
146
0
I too have this issue on my late 2008 MBP I have my dock to automatically hide. And it doest pop up anymore. Things were working fine earlier. Now i can't seem to do anything. I'm really pissed off. I think I'm gonna have to reinstall 10.6 :-(
 

Signal-11

macrumors 65816
Mar 23, 2008
1,475
2
2nd Star to the Right
This shouldn't matter but....

How many of you on the early 2008 MBPs were using the multitouch kext hack on 10.5?

Console errors (as brought up on the Apple support forums):

Code:
30/03/10 16:12:48	kernel AppleUSBMultitouchDriver::validateChecksum 
- 18-byte packet checksum is incorrect 
(expected 0x3af, checksum bytes were 0xb5e)
How many of you applied the applied the combo update?

Driving me nuts....
 

Vonswanko

macrumors regular
Oct 18, 2008
193
0
Well its not really a fix as much as a work around, but I am using JItouch, and has cured my issues. Lets see if Apple gets something working soon.

JITouch link here
 

88888888

macrumors 6502a
May 28, 2008
503
0
Same here.. wtf it's gettting really annoying.
I'm early 2008 MBP.
i didnt use the hack.
 

Beaverfish

macrumors regular
Dec 15, 2008
146
0
Has anyone tried an erase and install of snow leoprad. My MBP is pretty much unusable at the mo :-(
 

mac donalds

macrumors newbie
Mar 18, 2010
5
0
Has anyone tried an erase and install of snow leoprad. My MBP is pretty much unusable at the mo :-(
some people in the other thread did that and it fixed the problem.

Has somebody informed apple about this??? They need to fix this mess! I need to work with that machine.

I`m going to email apple now.
 

hmadacompaq

macrumors newbie
Mar 31, 2010
15
0
i have this problem also
when h press reject it show me message shutdown and sleep and restart

i think i have to format or downgrade sno
 

Beaverfish

macrumors regular
Dec 15, 2008
146
0
some people in the other thread did that and it fixed the problem.

Has somebody informed apple about this??? They need to fix this mess! I need to work with that machine.

I`m going to email apple now.
Can you please post your email and any responses you get from apple?