10.6.5 and still no HDMI audio.

Discussion in 'MacBook Pro' started by Ritte, Nov 12, 2010.

  1. Ritte macrumors regular

    Joined:
    Sep 14, 2007
    #1
    I've updated to 10.6.5 but I've still no luck with getting audio out of my mini displayport using hdmi. My mdp adapter is specified to support hdmi 1.3b and audio.

    What's the reason for this? Bad adapter, faulty mbp ur unluck with os update?
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
  3. perfectshadows macrumors member

    Joined:
    Mar 3, 2010
    Location:
    England
    #3
    HDMI audio support only works with mid 2010 MBPs I thought?
     
  4. chazco macrumors member

    Joined:
    Aug 22, 2010
    #4
    HDMI audio works on 2010 13" MBP

    Audio out via HDMI works fine on my mid-2010 13" MBP.

    The first time you use it you need to select your TV as the sound output device though (System Preferences->Sound->Output). After that it'll remember your setting and use the TV speakers when it's connected.
     
  5. Sti-R macrumors member

    Joined:
    Jun 7, 2009
    #5
    I'm pretty sure if you don't have the newer 2010 MBPs, then, it's more of a hardware issue rather then software. Simply, no amount of software update will provide audio out for older generation laptops.
     
  6. Ritte thread starter macrumors regular

    Joined:
    Sep 14, 2007
    #6
    Wirelessly posted (Mozilla/5.0 (iPod; U; CPU iPhone OS 3_1_3 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7E18 Safari/528.16)

    I've the new one with i5 released in June.
    So it should support audio. But I can't choose anything else than internal speakers in the options.
     
  7. chrisu91 macrumors regular

    Joined:
    Jun 28, 2010
    Location:
    Ontario, Canada
    #7
    I had the same issue but found out how to fix it. Plug in the cable and make sure your TV is ON and receiving the signal. Then, leaving the cable connected, go to your Sound settings in system preferences. Click the Output tab, and click on the TV instead of Internal Speakers. Sound should now come through the TV. When I first got it sound would not come through the TV so I messed with the settings and found out that was all you had to do.

    Hope this works for you!
     
  8. krizz macrumors newbie

    Joined:
    Mar 16, 2010
    #8
    Weird, my hdmi audio has been working under 10.6.4 very well.
    I'm on a i7
     
  9. Ritte thread starter macrumors regular

    Joined:
    Sep 14, 2007
    #9
    I don't have the option to choose anything but the internal speakers.
     
  10. aeboi macrumors 65816

    aeboi

    Joined:
    Sep 20, 2009
    Location:
    Bay Area
    #10
    the adapter probably doesn't support audio (even though it says it does), try the adapter on another MB/P if possible
     
  11. coochiekuta macrumors 6502

    Joined:
    Nov 6, 2010
    Location:
    here and there

Share This Page