10.6.5 update drop gaming performance?

Discussion in 'MacBook Pro' started by neenja, Dec 10, 2010.

  1. neenja macrumors 6502

    Joined:
    Jul 17, 2008
    #1
    MBP 2.4ghz (MBP4,1)
    4gb ram, geforce 8600m gt

    Before the update I was gaming perfectly fine on pretty much Medium - High settings. The only game I have been playing lately is HON - Heroes of Newerth. Everything ran exactly as it should and I never had any problems.

    However, a couple of days ago I booted up the game and tried to play and noticed my FPS dropped by A LOT. I even tried cranking down everything to low, and all it does is make everything pixelated, but my fps does not move at all.

    I then realized the day before, I ran Software Update and ended up bumping up to 10.6.5. I honestly cannot think of what other reason in why performance would drop. I ran both a disk permission repair and a verify disk repair. Ran onyx to do a clean up scan.

    Flash online, video files, music, everything else I have tested is performing as it should.

    Anyone else having issues with the recent osx patch?
     
  2. Stvwndr219 macrumors 6502

    Joined:
    Jan 26, 2009
    #2
    My FPS has stayed fine (same model but the 2.5 Ghz). Maybe you're finally getting to that 8600m GT of death place in your MBP's life?
     
  3. neenja thread starter macrumors 6502

    Joined:
    Jul 17, 2008
    #3
    i was thinking the same thing.. but the game works wonderfully on bootcamp win7
     
  4. aimbdd macrumors 6502a

    Joined:
    Dec 10, 2008
    Location:
    East Cost
    #4
    Mine was improved almost double with the update. It may be on its way. I havn't heard of anyone complaining it made it worse, that was 10.6.4.
     
  5. abrasive macrumors newbie

    Joined:
    Jun 26, 2010
    Location:
    Seattle, WA
    #5
    i noticed a very specific issue with starcraft 2 after the update. it only appeared after being applied.

    upon quitting the game, the resolution will be constrained to the smaller, unscaled letterbox of non-native res (1680x1050, what the game runs at), and the display's pref pane wont allow me to change back to default (1920x1200). additionally, a second display res window pops up as though there was another monitor, also accomplishing nothing. have to reboot to fix this. very strange and random problem. never encountered it before 10.6.5
     

Share This Page