10.6 Killed "Adobe PDF Printer" now how do I print booklets (CS4 Indesign)

Discussion in 'Design and Graphics' started by mainomega, Sep 18, 2009.

  1. mainomega macrumors 6502

    Joined:
    Jun 5, 2007
    #1
    Guys,
    I'm in need of assistance. We have been using Leopard and CS4's InDesign to create some brochures. We upgraded to Snow Leopard and everything was fine but now when we needed some brochures printed. We went to InDesign, selected booklet print but the print to pdf option was gone.

    Searching the internet I learned that it has been disabled in SL. A solution was to save to PF and use Distiller to convert to PDF... the problem is regardless of the settings the PF comes out portait (instead of landscape) and chops off our design.

    Is there something that can be done ? We are just thinking of moving everything to leopard this weekend if we can't get a fix.

    Apple/Adobe what have you done !?
     
  2. telecomm macrumors 65816

    telecomm

    Joined:
    Nov 30, 2003
    Location:
    Rome
    #2
    Your best bet is to post something in Adobe's InDesign forum. (The Acrobat forum's already got a big thread about all the PDF creation problems with Acrobat + Snow Leopard.)
     
  3. panoz7 macrumors 6502a

    panoz7

    Joined:
    Nov 21, 2005
    Location:
    Raleigh, NC
    #3
    Are you sure you have the settings correct in the print to postscript dialog? I've found it to be finicky in the past.
     
  4. margot macrumors newbie

    Joined:
    Dec 10, 2008
    #4
    Did you ever figure it out?

    Did you ever figure out how to fix your print booklet problem? I tried the same thing--printing to postscript and then distilling. But Acrobat always distilled to portrait...I really need this function, either through a fix or an add-in.

    Thanks, Margot

    ps. I upgraded to 10.6.2--Photoshop and InDesign are way more stable, but still no pdf printer
     
  5. panoz7 macrumors 6502a

    panoz7

    Joined:
    Nov 21, 2005
    Location:
    Raleigh, NC
    #5
    Sorry to repeat this, but are you sure you have it set up right, specifically the page setup dialog? I only ask because I just tried it and it worked fine. Indesign CS4 --> .ps --> Distiller --> PDF worked on my MBP running 10.6.2.

    I recently reinstalled snow leopard and cs4 after experiencing stability problems after 10.6.2, so that test was done on an almost completely virgin system. If you've triple checked and you're sure the dialog is right, maybe it's a plugin or something that's interfering. Adobe software can be infuriating with small stuff like this... why can't a book be exported straight to PDF without having to "print" it anyway?

    EDIT: FOUND THE BUG. I just tried printing it again, but this time with the ppd set to device independent. In that case I get the issue you were describing. I'm not sure what's going on, but perhaps the workaround is setting a printer and then a paper size?

    And here's an adobe forum thread that seems to have some solutions: http://forums.adobe.com/thread/487877
     

    Attached Files:

  6. sepirioth macrumors newbie

    Joined:
    Jun 2, 2010
    #6
    My solution to all this pdf headache

    In short, I installed CUPS-pdf (google is your friend)
    It creates a printer called (duh0 cups-pdf on your list. Allows you to print booklets etc without a hassle. It does NOT allow you to change the path or name but instead put it in a predetermined folder (/Users/Shared/CUPS-PDF) which you can create an alias for to your desktop. The files ARE huge but you can open it in acrobat and re save it where ever you want with a smaller size and change the name etc. Its basically one extra step but MUCH easier than any other solution I've seen on the web so far.

    I hope this is not against the forum rules... but here is a link to the CUPS-PDF site
    http://bitbucket.org/codepoet/cups-pdf-for-mac-os-x/wiki/Home
     
  7. wilsonlaidlaw macrumors 6502

    wilsonlaidlaw

    Joined:
    Oct 29, 2008
    #7
    Print to PDF working for me in 10.6.3

    It seems to be working for me in 10.6.3. I have tried from a number of programs and whenever I do Cmd-P, at the bottom of the print dialog box, on the PDF drop down, I can save as a PDF. Surely this is identical to print to PDF?

    Wilson
     
  8. ksuchm macrumors newbie

    Joined:
    Jun 28, 2010
    #8
    Tried CUPS-PDF and still having issues

    I downloaded the CUPS-pdf application previously noted, but everything is outputting to an 8.5 x 11 page instead of 11 x 17 spreads even though the document settings in print booklet are set properly. This is incredibly frustrating! Any other suggestions would be appreciated.
     
  9. Blue Fox macrumors 6502a

    Blue Fox

    Joined:
    Apr 13, 2009
    #9
    Same here. Mine has been working fine in CS3 and all other programs as well, and I'm running Snow Leopard 10.6.4, and has been working ever since I upgraded to 10.6. I'm not sure what everyone is on about with it not working, unless we are misunderstanding what they are trying to do.
     
  10. telecomm macrumors 65816

    telecomm

    Joined:
    Nov 30, 2003
    Location:
    Rome
    #10
    It's not.

    You're both misunderstanding.

    "Save as PDF" uses Apple's PDF engine to go create PDFs, while the New "Save As Adobe PDF" (available under the same "PDF" button in the Print popup) uses Adobe's PDF engine (which you probably don't have if you're not sure what we're all talking about).

    Neither of those two current options behave like the previous option, which, for example, would allow you to batch covert 1000 Word files to PDF without having to select Print>PDF>Save as PDF 1000 times.
     
  11. emcarnahan macrumors newbie

    Joined:
    Feb 18, 2010
    #11
    @panoz7

    thank you so much -your solution worked beautifully! I know you saved me umpteen hours of frustration..!
     

Share This Page