10.6 - 'No Services Apply' in Finder - Column View Only

Discussion in 'macOS' started by Jolly Jimmy, Sep 18, 2010.

  1. Jolly Jimmy macrumors 65816

    Jolly Jimmy

    Joined:
    Dec 13, 2007
    #1
    The services I use that work on files and folders in Finder do not appear in the services menu when a folder is highlighted in column view. Instead I see a 'No Services Apply' message. The strange thing is that they all work flawlessly on files and folders when run from the services menu in any other view (icon, list or cover flow) or the right click menu in any view. This is frustrating because the shortcuts I assigned do not work in column view.

    I tried this but it didn't help.

    Thanks for any input.
     
  2. Corndog5595 macrumors 65816

    Joined:
    Jul 16, 2010
    #2
    This is because when you select a folder in column view, you are opening that folder. Therefore, when clicking a folder in column view, you are actually selecting nothing.
     
  3. Jolly Jimmy thread starter macrumors 65816

    Jolly Jimmy

    Joined:
    Dec 13, 2007
    #3
    Thanks for the reply.

    But it doesn't really make any sense. I can still select a folder and use other shortcuts like 'Duplicate' or 'Make alias' in column view so there's no reason why it shouldn't work for services too.
     
  4. bartszyszka macrumors member

    bartszyszka

    Joined:
    Dec 7, 2004
    Location:
    New York, NY
    #4
    This still seems to be an issue in Lion. It doesn't make sense at all. There is an item that is selected, it has a blue background color. The service should apply to the selection.
     

Share This Page