10.6: Spellchecker issue

Discussion in 'macOS' started by Nermal, Sep 2, 2009.

  1. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #1
    Hi,

    I have my system language set to British English and I'm having some problems with the spellchecker. It's reporting words like "colour" as incorrect, and offering "colour" as a suggestion. Is this happening for anyone else?

    Thanks :)
     
  2. broken-chaos macrumors regular

    broken-chaos

    Joined:
    Sep 2, 2009
    Location:
    Toronto, Ontario
    #2
    Check the Text part of Language & Text. You may need to properly setup the automatic-by-language spelling check for the proper languages in the proper order (i.e. British English above US English, or just disable US English entirely).
     
  3. Nermal thread starter Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #3
    Aha! Yes, under Text I had to change "Spelling" to British English. Way to complicate things, Apple...

    Thanks for the help :)

    Edit: I actually wonder whether it's a bug. If it defaults to use the system language for spellchecking, then it should respect that instead of using American. Is anyone able to replicate this issue?
     
  4. Nermal thread starter Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #4
    I'm just resurrecting my own thread here...

    The spellchecker language under the Text tab will "randomly" change itself back to US, instead of staying on British, resulting in "colour", "optimise" etc being listed as wrong. Has anyone else run into this issue?

    ... it even changed itself while I was typing this post! :eek:

    Edit: I just found that you can choose "Setup" from the language list, which gives a list of all languages where you can rearrange and disable them. I've moved British to the top and disabled US. Let's see whether that works.
     
  5. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #5
    Seems to me that the other option would have been to select one and only one "version" of English. Would you be thanking Apple then if they didn't select the one you use?

    Anyway, hope your new discovery makes the choice stick this time.
     
  6. Nermal thread starter Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #6
    In 10.5 and earlier, the spellchecker respected the system-wide language setting, and you therefore didn't have to change it in two different places. That's what I meant by Apple overcomplicating things. I appreciate that there's now an option to have the OS language and spellchecker set differently, I was just confused at the time since the setting had become "hidden".

    The settings have stuck so far :)
     
  7. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #7
    I see. Maybe I didn't read carefully enough. Hope it continues to retain the setting for you...
     

Share This Page