10.7.2 and safari on secure campus

Discussion in 'Mac OS X Lion (10.7)' started by sa gringo, Oct 14, 2011.

  1. sa gringo macrumors member

    Joined:
    Jan 11, 2009
    Location:
    San Antonio TX
    #1
    I was running Lion 10.7.1 on my MacBook pro. Wireless connected without issues at school. The way wireless works at school is through an authentication page where you first select the WIFI and then open up safari and authenticate via username and password. After the update to 10.7.2, the page will not load at all.

    Check with school to see if there was any certificate issues, but they stated that nothing has changed. Tried different browsers Firefox, Chrome, but not luck. The page just pretends to load and it never does.

    The odd thing about this issue is that my friend is running Lion 10.7.1 and it works properly. So far there are three mac users w/ 10.7.2 and it is not working for them. So I am begining to think that the issue is related to 10.7.2.

    The computers are showing they have IP address just will not load login screen.

    Ideas ?
     
  2. ac3320 macrumors regular

    ac3320

    Joined:
    Aug 20, 2011
    Location:
    CA
    #2
    I was having similar issues with 10.7 and 10.7.1. What I found after some research was a suggestion to create a new "Profile" under the "Network" (Wi-Fi tab) of System Preferences. Mine was set to "Automatic" and I created a new one called "Default" -- and then turned Wi-Fi off, turned it back on and made sure I "found" the school's network, and then re-opened my browser to try and elicit the login prompt. It worked for me, hope it helps you too!
     
  3. joseftu, Oct 14, 2011
    Last edited: Oct 14, 2011

    joseftu macrumors member

    Joined:
    Jul 6, 2007
    #3
    We've got a couple of students reporting this exact same problem since going to 10.7.2 Their MacBooks connect just fine to networks anywhere else, but in their dorm, where they have to access an authentication page first, that page never loads. What changed in the wifi in 10.7.2?

    (Making a new profile didn't help).

    EDIT--the solution in this forum http://airheads.arubanetworks.com/vBulletin/showthread.php?t=4451 looks like a very good possibility. I'm having the students check...
     
  4. ctbear macrumors 6502a

    Joined:
    Dec 6, 2010
    #4
    My school's network uses a similar setup. As far as I know a pop up will appear when you connected to the access point. I'm pretty sure that's new for 10.7.2
     
  5. joseftu macrumors member

    Joined:
    Jul 6, 2007
    #5
    OK students report success with the solution (or workaround) mentioned in this thread http://airheads.arubanetworks.com/vBulletin/showthread.php?t=4451

    For anyone else having the problem, here's the way to fix it and get authorized and get on the internet again.

    =============
    Open Keychain Access. It's in Applications=>Utilities.

    Then in the Keychain Access menu at the top of the screen choose "Preferences..."

    Go to the pane labelled "certificates." Check the first two items there. (Online Certificate Status Protocol and Certificate Revocation List). Both should "Off." If they say "best effort" change them to "Off." Then you should be able to connect (may need to restart the computer, but maybe not).
    =================

    For those who want the somewhat geeky explanation, here's what I think is happening (I am FAR from an expert on this). Some networks (including the networks on many college campuses or dorms) use an Aruba access control system (and maybe some other brands). You're probably seen this kind of thing in other places--airports, hotels, coffee shops. This kind of system lets anyone connect to the wireless network, but then to actually do anything on that network like browse the web, get email, or whatever, you have to open a browser where you'll see a page that asks you to authenticate. Sometimes it requires a username and password, other times you just have to click the "I agree not to do anything bad" or "welcome to our Marriott" button. But in any case, unless you get through that page (the "captive portal"--isn't that a charming name?), you can't go any further.

    In the latest update, Apple made a new convenience where you can connect to the network, and then instead of requiring the "captive portal" there will be a separate popup window (a webkit window) which will appear and let you login without even opening the browser. Then you're good to go. This might be familiar if you have an iPad or iPhone, because this has been the case on those devices for some time. I guess the advantage is that if you want to connect to the network and check your email, you don't have to go through the bother of first opening your browser and trying to access a page in order to get that captive portal.

    But something went wrong with this in the latest update--seemingly ONLY on new MacBooks that had Lion installed from scratch. Anyone who upgraded from Snow Leopard seems not to have the problem. What I think is happening is that the browser is waiting for that webkit window to appear, and the webkit window is not appearing, because it's waiting for the browser to show the captive portal. Or something like that. Anyway, the workaround above does seem to work.

    I did NOT invent this solution, and I'm not even 100% sure I understand it. Hope it works for others!
     
  6. SamothLharts macrumors newbie

    Joined:
    Oct 17, 2011
    #6
    older machines are affected as well

    hi joseftu,
    finally somebody has found a solution. I'll give it a try once I'm back home and let you know if it worked for me. I also wanted to mention that I have a mid-2010 MacBookPro that came SnowLeopard pre-installed on it. Upgrading to Lion screwed up things for me, not 10.7.2. Same deal though: public network from British Telecom, which is accessible for their customers with a password and username.
    Thx,
    Samoth.
     
  7. sa gringo thread starter macrumors member

    Joined:
    Jan 11, 2009
    Location:
    San Antonio TX
    #7
    Well on Monday is it working on and off. The following warning was put on the homepage for those who can access:

    IMPORTANT!
    MAC (LION OS) USERS ONLY – if possible do NOT accept the most recent Safari update.
    The recent update from Apple appears to also affect MAC Java. (Apple has its own Java virtual machine -- it's different than the one downloadable from Sun Microsystems.)
    MAC users who updated Safari and run sites requiring Java reported problems. (The HSC Air authentication page and Blackboard require Java). During tests the Bb entry page does not load. There is no error message; the page just doesn't load anything at all. This could be perceived as Blackboard being down. Bb is fully accessible and functioning.
    Desktop support was able to duplicate the problem with different browsers.
    Desktop support is looking into the issue and will keep you informed.
    Digital Signature Verified: You may see a Warning-Security pop-up, check the box to "Always trust content from this publisher" and click RUN
    Remember to disable your Pop-up Blocker as well.
    Please consult the Top 10 Technical Tips and other information below
    Faculty Forms: Blackboard and ATS Requests
    For assistance, please contact Blackboard support at 567-7777, Option 4.
     
  8. xjosh macrumors regular

    Joined:
    Jan 7, 2011
    Location:
    Denmark
    #8
    This works 100% - tested on three macbook pros. Thanks!
     
  9. rgetter, Oct 28, 2011
    Last edited: Oct 28, 2011

    rgetter macrumors newbie

    Joined:
    Sep 20, 2008
    Location:
    Portland, Oregon
    #9
    Possibly better solution, delete Ubiquity folder

    I found this idea in a story on MacWorld today. Get rid of the Ubiquity folder (used for iCloud certificiates) in ~/Library/Application Support/ and restart. For me, authentication came back and I no longer had the problem of Keychain Access freezing when I restarted it.

    I had tried joseftu's solution on a few Lion machines here without success and have more testing to try with this. But it seems to work.

    Ric
     
  10. SgtP3pp3r macrumors member

    Joined:
    Mar 29, 2011
    Location:
    Honduras
    #10
    This seemed to have worked for me! Have to test it further tho, but just now the authentication problems went away. I'll edit this post if i have further issues.
     
  11. tobiasfunder macrumors newbie

    Joined:
    Jun 8, 2011
    #11
    Well i for one have a MBP 15" mid 2010 which i have upgraded to Lion. After installing the 10.7.2 update i ran into the exact same problem with the wifi on my school. So i don't think its related only to new macs with lion installed from scratch, since i upgraded mine from snow leopard.
     

Share This Page