10.7.3 Lion - no "new" mail alert

DTaylorB

macrumors newbie
Original poster
Mar 13, 2012
2
0
i have looked everywhere for the solution to this. i thought i had found the solution (see below), but i do not have a "mail" folder in my library...help! :)

Here are the exact steps they had me follow to get to that location:

1. Click Finder in the dock
2. Press and hold the Option Key
3. Select Go-->Library from the menu bar (still holding down the Option Key)
4. Double Click the Mail Folder
5. Double Click the V2 Folder
6. Double Click the MailData Folder

You should see the "Envelope Index" files there.
3. Move all "Envelope Index" files to the desktop - for me there were of them.
4. Restart Mail - I received a message that mail had to import files, I hit continue and when it was done (took about 5 minutes to process all 6 accounts I have) everything was back to working right.
 

r0k

macrumors 68040
Mar 3, 2008
3,612
73
Detroit
In finder, go to preferences and pick show hidden files. Now go to your home folder. This is one folder above your Downloads and your Documents folders. From there you should be able to see your Library folder and find the mail folder you were looking for from there.

If you like, you can turn show hidden files back on when you are finished.
 

DTaylorB

macrumors newbie
Original poster
Mar 13, 2012
2
0
i don't think it is a hidden vs non hidden..?

i can see the library, can't see the mail folder
 

sidewinder

macrumors 68020
Dec 10, 2008
2,425
127
Northern California
Try this:

Quit the Mail app and go to this directory:

~/Library/Mail/V2/MailData/

Delete these files:

Envelope Index
Envelope Index-shm
Envelope Index-wal

Restart the Mail app. Don't freak out when you get the "Mail Message Import" dialog. Just hit "Continue".

You can use the Terminal.app to do this. Quit the Mail.app. Then, run the Terminal.app. In the Terminal.app, type:

cd ~/Library/Mail/V2/MailData/

and hit return.

Then type:

rm Envelope*

and hit return.

Quit the Terminal.app and restart the Mail.app.

S-