10.7.4 - Can't Change Computer Name

Discussion in 'Mac OS X Lion (10.7)' started by wshep49, May 12, 2012.

  1. wshep49, May 12, 2012
    Last edited: May 13, 2012

    wshep49 macrumors newbie

    May 12, 2012
    After upgrading from Lion 10.7.3 to 10.7.4 I cannot change the computer name in the Sharing Preferences window.

    I'm working in a computer lab with 25 iMacs. The lock at the bottom of the window is unlocked. I can change the Bonjour name by clicking the Edit button, but not the Computer Name. The name in the text box is greyed out. I have tried unbinding from AD and LDAP. I have tried rebooting. No luck.

    Has anyone else notice this and/or does anyone have a solution?


    Okay, I found a solution for this.

    The computer had been bound to a Mac Server before the upgrade from 10.7.3 to 10.7.4 The fix is to re-bind the computer to the Mac server (running 10.7.4) then connect to the Mac server using Workgroup Manager and disable server control of the computer's System Preferences at the server. Once this was done I was able change the computer name in the System Preferences --> Sharing text box.

    Even though the Sharing system preference wasn't specifically controlled by the server and even though I had previously unbound the computer from the server there was apparently still something on the local computer that thought it was controlled by the server.

Share This Page