10.7.5/Time Machine SLOOOW backups?

Discussion in 'macOS' started by dcains, Sep 27, 2012.

  1. dcains macrumors regular

    Joined:
    Mar 27, 2007
    #1
    I've got 3 (2007 and 2008) Macbooks (Lion 10.7.5) and have been backing them up for at least 3 years to a 1TB Time Capsule. The other day one of the Macbooks had a harddrive fail and it was replaced by a brand new 320GB WD Caviar Blue. The restore of about 40GB went flawlessly and took maybe an hour and a half. So far, so good. Since the TC has had all those old backups since January, and I didn't think I'd need them, I decided to erase the TC and start fresh.

    I first tried to backup the Macbook with the new harddrive to the TC, using an ethernet connection, and several times the backup stalled. Once at around 4GB out of 40GB, and twice at maybe 7GB. Before the stalls, progress was very slow, with the time remaining showing as "about 2 days". So, I erased the TC again (via Airport Utility) and tried one of the other Macbooks, this one having about 120GB on its drive. Again, super slow progress, showing "about 3 days" remaining. What's going on here?

    Previously, I've backed up these Macbooks to the TC (January), using an ethernet cable, and it's only taken a few hours for about 120GB. I've done some Google searching, and see some mention that this is a 10.7.5 issue, while others state this is an issue with the TC overheating. To my touch, the TC doesn't feel excessively warm, and since the 10.7.5 update is very new, I've got no way to tell if that's a factor, or not. I also read that Spotlight indexing would slow down the initial backup, so I've turned that off.

    Anyone have any solutions to offer, or any definitive explanation for this issue? Thanks in advance.
     
  2. szleski macrumors newbie

    Joined:
    Mar 3, 2010
    Location:
    Poland
    #2
    I have the same problems on a MacBook Pro. This is quite a widespread issue judging by the number of posts in this thread:
    https://discussions.apple.com/thread/4324046?start=0&tstart=0
    (but maybe you have already seen the thread?)

    A temporary fix which worked for me was to disable Spotlight completely, as described in http://osxdaily.com/2011/12/10/disable-or-enable-spotlight-in-mac-os-x-lion/
     
  3. dcains thread starter macrumors regular

    Joined:
    Mar 27, 2007
    #3
    Thanks for the pointer. Turning off indexing using this Terminal command:

    "sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist"

    restored Time Machine backups to normal speed, but the one I previously tried:

    "sudo mdutil -a -i off"

    did not. I was able to backup ~120GB from one Macbook in about two hours, and ~36GB from another in about 45 minutes. While Spotlight is nice to have available, I'm happy to trade it off for normal speed Time Machine backups, at least until the "geniuses" come up with a permanent fix. Shame on Apple for letting such a huge bug slip into a final release. I switched to Mac's in '07, and have never seen an OS X update cause so much trouble.
     

Share This Page