10.7 clean install - WiFi stopped working

Discussion in 'Mac OS X Lion (10.7)' started by grani13, Mar 31, 2012.

  1. grani13 macrumors member

    Joined:
    Mar 31, 2012
    #1
    Hello,

    I realise that there are a lots of problems with Lion and WiFi, but unfortunately I haven't been able to locate a resolution to my particular problem.

    I am on an iMac (2009, i5). Until a couple of days ago I have been running 10.7.3, upgraded from a 10.6 installation. Everything was working fine.
    Due to a couple of issues I decided that it is best to erase the disk and make a clean install, this time from a 10.7 boot disk.

    The installation went fine but ever since I cannot connect to my router using WiFI. I can connect to the router and internet via Ethernet and cable without any issues.

    As far as the WiFi goes, the iMac can connect to the router, that's fine, but there is an exclamation mark in the wireless icon and the "alert: no internet" message.

    I can only get self-assigned Ip addresses, and no connection. Entering internet settings (IP, subnet, router...) as they should be manually does not work. Renewing DHCP lease does not work.

    I have upgraded to 10.7.3 from the clean install and also installed the WiFi upgrade - without success. I have tried deleting preferences (airport...) without success.

    I do have a macbook pro sitting next to the iMac, running 10.7.3 (upgraded from 10.6) connecting to the very same router without problem. A router problem is thus improbable.

    Is there any known fix to handle the issue? What are my options? Do a clean install of 10.6 and then install 10.7 over it?

    thanks in advance
    grani13
     
  2. wilsonjm macrumors newbie

    Joined:
    Jun 2, 2009
    Location:
    Munich, Germany
    #2
    Hi,

    I've had this problem ever since I setup my 2011 iMac, which came with Lion preinstalled. Tried all the workarounds that were suggested, none worked and now I've given up.

    I'll just keep the network cable connected until Mountain Lion and hope they have fixed the issue.

    Pretty shocking from Apple this one. And as a damning aside, I run Windows 7 on bootcamp and that works no problem on wireless. So an Apple "It just works" product does not work using a years old technology whereas the much-derided Windows works perfectly.

    Makes you laugh really doesn't it?

    Anyway, no big deal. Some things in life are just not that important.

    Regards,

    JW
     
  3. blatopilot macrumors regular

    Joined:
    Sep 24, 2011
    #3
    What router is it?

    I had this issue with an Airport Extreme and I had to reset it. Once I reset it, Lion behaved so much better.

    Unplug the power from your router, then do the same with your modem. Give it a couple of minutes, then plug in your modem. Let that come to life and get all the lights where they should be then plug in your router.

    If it is an extreme, take a pen or similar and push in the little button on the back. It should be out of commission for a few minutes after that and then fire back to life.


    This simple thing added years to my life.
     
  4. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #4
    Plus on the new Lion Mac try this:

    1. Open System Preferences->Network pane. Then their see if the Airport card is sowing up!

    2. Then at the top of the pane is the 'Location' drop-down, click on it. Select 'Edit' and then the + button to add a custom named Location (like Home). Then save that new Location,

    3. After creating that new custom named Location click on the Airport card and join your wireless network from this Network pane. See if it will join your wireless network (it better be WPA2 wireless security!).
     
  5. grani13 thread starter macrumors member

    Joined:
    Mar 31, 2012
    #5
    I got tired of this problem, but found a solution:

    I formatted the hard disk and installed 10.6. Wifi was up and running from the first reboot onwards. I then just updated to 10.7, and it is still working.
    Not quite what I intended to do, but at least it works...

    Have to agree with wilsonjm - this is vey shocking from Apple. Probably the poorest thing I have seen ever since I started using them.

    Thanks to satcomer and blatopilot for the suggestions, I had already tried those as well without success. My router was working fine at all times (had a MBP connected using WiFi sitting next to the imac). There is clearly a major issue with the 10.7 installation...
     
  6. Yogakun macrumors member

    Joined:
    Jul 28, 2010
    #6
    Ever since the latest upgrades and other upgrades to Lion I've been having issue's connecting to LION on my network.

    I connect flawlessly to my connection with my other devices and computers. Currently I"m using bootcamp and it's kept a solid connection for 3 weeks now, as opposed to Lion which was disconnecting every 10-15 minutes.

    This pathetic that Apple can't solve this issue. Never in the history of computers have I ever experienced such a joke of customer service. I haven't heard any press releases from them either telling customers they are aware and solving this issue.

    The fact that I'm denied from using the product that I paid over thousands of dollars a few months ago, that is only half way through warranty is a joke.
     
  7. wilsonjm macrumors newbie

    Joined:
    Jun 2, 2009
    Location:
    Munich, Germany
    #7
    Hi Grani13,

    Just tried another workaround...

    Using Network Utility to send a constant ping to a google public server (8.8.8.8) reduces the wi-fi drop-out from a few seconds to several minutes, sometimes half an your or so. When it drops I turn off wi-fi and turn it back on.

    I also just changed the channel my router uses (connected using a browser to 192.168.1.1). It was set to auto and I changed it to 7 (this one was not being used by any other wi-fi network in range).

    I am still using the constant ping and with also the channel change I have not had a dropout for over half and hour now. Will wait a short while longer and then stop the ping.

    Fingers crossed...

    PS When I was changing the router channel, my router webpage showed me a list of channels being used with range. If yours does not show this, you can use a program called iStumbler - http://www.istumbler.net/
     
  8. wilsonjm macrumors newbie

    Joined:
    Jun 2, 2009
    Location:
    Munich, Germany
    #8
    The next day...

    My problem is still there but nowhere near as bad as at first. I keep the constant ping running (to either my router or to an external address, doesn't seem to matter) and the connection drops maybe once an hour.

    Far from perfect but good enough for me to not have to use the ethernet cable.

    Regards

    JW
     
  9. wilsonjm macrumors newbie

    Joined:
    Jun 2, 2009
    Location:
    Munich, Germany
    #9
    and now it has improved.

    Only 1 dropout the whole day yesterday and none so far today.

    No more ethernet cable for me.

    JW
     

Share This Page