10.7 iTunes Won't Open, error -200??

Discussion in 'Mac OS X Lion (10.7)' started by rmbrown09, May 9, 2011.

  1. rmbrown09 macrumors 6502a


    Jan 25, 2010
    I get this when I try and open itunes...
    Edit: happens when I restart my computer as well, without my opening the app. Going to delete the application support folder.

  2. uaecasher macrumors 65816


    Jan 29, 2009
    Stillwater, OK
  3. rmbrown09 thread starter macrumors 6502a


    Jan 25, 2010
  4. mrapplegate macrumors 68030

    Feb 26, 2011
    Cincinnati, OH
    They are having same issue. This helped one user:
    2)Start in safemode by pressing and holding shift while powering on, this might take some time.
    3)Open itunes, it will open but without sound.
    4)Restart normally again and everything will be fine
  5. rmbrown09 thread starter macrumors 6502a


    Jan 25, 2010
    Gave it a shot, iTunes didn't open and now audio on my machine is gone as a whole. I restarted normally however I have no sound what so ever.
  6. mrapplegate macrumors 68030

    Feb 26, 2011
    Cincinnati, OH
    That thread lists others as well. Follow those, I'm sure they will help you.
    Here is another suggestion:
    Boot into single user mode, deleted /private/var/db/dyld contents, then went ahead wiped out vm files and all system caches (not user caches). I rebooted the machine and voila, volume up/down feedback works and iTunes starts up fine.
    I have not tried but I suggest you follow the thread and read what others link to as well.
  7. pslocom macrumors newbie

    May 19, 2011
    Amazingly enough doing this fixed my sound!!!! I am so excited, listening to iTunes right now!

    To recap, here is what I did:

    Reboot into safe mode, hold shift during boot (takes a while but eventually it will load)
    Logged in
    Opened iTunes (no sound, but it opened at least for me)
    Closed iTunes
    Opened Terminal
    Removed contents of /private/var/db/dyld
    Removed contents of /Library/Caches (The Library folder at your drive root, not in your user/home folder)

  8. rmbrown09 thread starter macrumors 6502a


    Jan 25, 2010
    Can confirm just did the same steps and have sound back.
    Can someone explain though what I just did? And why that fixes the sound?

    what is a dyld
  9. pslocom macrumors newbie

    May 19, 2011
    From some quick reading on wikipediaa dyld, or Dynamic Linker seems to work between actual hardware and the software/OS. My theory is that (note my development experience stops at BASH scripts and PHP) these files were used as a middle man between API-like calls to the OS for audio, etc. My guess is that programs that need a little more control over the hardware resources, such as some games, things like Skype, etc don't typically use those linkers which would explain why they work.

    Like I said, just a theory, so don't quote me on it.

    As far as the cache folder goes, I'm guessing that's more of a precautionary measure. Just in case the OS has something bad cached, we might as well get rid of that stuff so it can rebuild a fresh copy.

    I welcome corrections by someone who know a little more about this stuff, I'm just making my best educated guesses.

    I'm glad it worked for you too! Wish I could take credit for the original idea! :p Hopefully other people having the same type of issues will see this and get their sound fixed too.
  10. ktonini macrumors newbie

    Jan 3, 2008
  11. rmbrown09 thread starter macrumors 6502a


    Jan 25, 2010
    After DP4 I am in the same boat as when I installed DP3, except iTunes still works.

    I have Reefit installed so holding shift isn't putting me into safe mode. Is there a way to boot into safe mode with terminal?

    Or do I need to uninstall it.
  12. peoplayer macrumors newbie

    Jun 25, 2011
    Commands in Terminal

    I am a noob and would like to know the exact commands to navigate to these folders and erase the content in them?
    Thank you!
  13. xodus macrumors newbie

    Aug 22, 2006
    Toronto, Canada
    I can confirm the above method worked for me and I am also using rEFIt. I am running 10.7 (11A511) on a late 2007 MB (C2D 2.2 GHz).

    1. Apple Menu>Restart
    2. Hold shift as computer boots *(start holding before rEFIt menu & while navigating rEFIt). Wait for computer to boot completely.
    3. Open iTunes, close it again after it opens fully.
    4. Open terminal (/Applications/Utilities)
    5. Navigate to directory using cd
    cd /private/var/db/dyld
    6. Remove files in directory dyld
     rm -ri *
    7. Navigate to Caches
     cd /Library/Caches 
    8. Remove files in directory Caches
     rm -ri * 
    9. Restart

    Always exercise caution when using the rm command since it can cause damage to the system if you go around removing files willy-nilly. Also I like to use the -ri argument so I know exactly what I'm deleting, you will need to confirm with y/n.
  14. AppleDApp, Aug 8, 2011
    Last edited: Aug 8, 2011

    AppleDApp macrumors 68020


    Jun 21, 2011
    I have the same Error as OP every post I read seems to talk about how to get audio in iTunes did any one post a solution to get iTunes to open? I am using lion.

    Edit: I also lost audio. I rebooted and everything seems to work fine.
  15. Quad5Ny, Aug 8, 2011
    Last edited: Aug 8, 2011

    Quad5Ny macrumors 6502a


    Sep 13, 2009
    New York, USA
    "sudo update_dyld_shared_cache -force", Restart
  16. dijonemon macrumors newbie

    Jul 28, 2011
    Worked for me, thanks!
  17. spkane macrumors newbie

    Nov 22, 2004
    Simply one line solution

    This worked like a charm! Thanks!!

    Save any open documents and then:

    $ sudo update_dyld_shared_cache -force && sudo shutdown -r now

Share This Page