10.7, volume controls not working

Discussion in 'Mac OS X Lion (10.7)' started by HellDiverUK, Jul 24, 2011.

  1. HellDiverUK macrumors 6502

    Joined:
    Oct 24, 2009
    Location:
    Belfast, UK
    #1
    Folks,

    Anyone else having problems with the volume control not working? The volume icon on the menu bar is greyed out, and pressing the F10/F11/F12 buttons don't adjust the volume.

    BUT the sound still works, but is stuck at full volume.

    It was working for a few days after upgrade, but now it's not. I've rebooted a few times, but still lots of sound and no volume control.

    Any clues?

    It's on a MacBook Pro 13" Mid09 model (2.53GHz, 4GB).
     
  2. Adambomb13 macrumors newbie

    Joined:
    Jul 14, 2011
    #2
    I too am having the exact problem, resetting PRAM works sometimes, I also tried deleting plist sound files, no go. I have created a new users, no go. I have ran Apple hardware test, nothing detected. Yes plugging in the headphones works until I reboot or shutdown still irrating...I have been working on this issue all day... I just called an Apple Store and they to have heard of this and recommended a fresh install of Lion or wait for an Apple fix through Software Update

    Adam
     
  3. zorp macrumors newbie

    Joined:
    Jul 13, 2011
    #3
    Removing Airfoil fixed it for me

    Hi, I had the very same problem with sound controls not working after upgrading to Lion. I had AirFoil installed and tried to uninstall the app and restart, that worked like a charm.

    So If you have airfoil installed try and remove the app. Use Appzapper to do it quick and easy.
     
  4. EdwinG macrumors newbie

    Joined:
    Feb 26, 2011
    #4
    me too, 09 mbp, but it's only greyed while booting to 32 bit. under 64 bit, volume control works no issue.
     
  5. innominato5090 macrumors 6502

    innominato5090

    Joined:
    Sep 4, 2009
    #5
    same problem here. I have to kill coreaudiod via terminal (i.e. sudo killall coreaudiod) to make them working again.
    it's surely related to some kind of app we have installed cause I had that issue on the DP4, GM and now on the MAS version (clean install every time)
    apps that we should investigate on
    • istat menus
    • Xcode 4.2 beta
    • adobe cs5.5
    does someone have at least one of these apps installed?
     
  6. gazzamac macrumors member

    Joined:
    Jan 17, 2010
    #6


    I have exactly the same issue after a fresh install to a cleanly partitioned drive using a DVD install of Lion so can rule out any app causing this issue.
    I can confirm that killing coreaudiod does fix the issue for me.

    Taking no credit from innominato5090's superb fix I did it slightly different. (red number is the process id)

    open terminal

    bash-3.2$ ps -ef |egrep -v grep |grep coreaudio
    202 136 1 0 10:22am ?? 0:25.21 /usr/sbin/coreaudiod

    bash-3.2$ sudo kill 136
     
  7. lfc macrumors regular

    Joined:
    Oct 20, 2010
    Location:
    Australia
  8. hooly macrumors regular

    hooly

    Joined:
    Nov 19, 2007
    #8
    Same issue here.

    Installed Lion when it came out. Last few days the volume buttons and slider do not work and I am stuck on a set volume.

    (i) restart does not help
    (ii) shut down and wait before restarting is a temporary fix but it re-occurs
    (iii) above solution (plug in and unplug headphones) also works so far, presumably temporarily.

    I do not have the above mentioned software installed (adobe etc), but I do have airfoil. Also I first noticed the problem after using my Audio MIDI settings to use iPad as a Mac GarageBand controller - but those settings are definitely as they should be for on board audio so I suspect this is a coincidence.

    I'll keep my headphones handy - at least it only seems like a software issue (I was worried about hardware/logic board on my 11 month old Mac)
     
  9. mgarciap macrumors newbie

    Joined:
    Mar 30, 2009
    #9
    Brilliant! Solved the problem!

    Plug/Unplug headphones did the trick.

    THANKS!!!!
     
  10. michael.ruta macrumors newbie

    Joined:
    Feb 14, 2012
    #10
    this trick works for me

    this works for me too, when volume controls are not working,

    plug an earphones and just at the time when your speaker stops
    and your earphones is about to initialize, unplug the earphone immediately,
    then the system will return to play speakers and the volume controls in the menu bar, systems prefs> sound, and keyboard, everything else.. will work again
     
  11. kayakerles macrumors newbie

    Joined:
    Jun 7, 2009
    #11
    Turning Volume button functionality back on.

    Try going to System Preferences > Sound >Output > make sure you're set to "internal speakers" and your volume button should work again.

    I just (yesterday) installed a program to rip music from Spotify called "AllMyMusic" by Wondershare. It redirects my output to itself, and turns off my volume control button. Perhaps you added something that stole the control away too.

    Hope this does it for you. ~ Les

     
  12. bpmacme macrumors newbie

    Joined:
    Feb 5, 2010
    Location:
    Atlanta, GA
    #12
    Volume Controls only not working on Builtin Output

    I appear to be having the same problem as you are stating here. The volume menu button goes grey and my buttons do not work on my keyboard. However, this is only the case for my built-in output (main MBP speakers). On my bluetooth headphones, when they are connected, it works just fine. Then when I detach them, the volume doesn't work again. It started happening when I was looking into using a multi-output device in the Audio MIDI Setup application in utilities (wife and I use headphones at the same time of bluetooth and plugin type). Now it just stays broken, no matter what I do.
     
  13. ZenFire macrumors newbie

    Joined:
    Feb 25, 2011
    Location:
    Los Angeles, Chicago, London, Hong Kong
    #13
    Works with WIRE, yet not with TOSLINK

    When I plug in a wire to go to the amp, or headphones, no problem, the F10,11,12 and slider work fine.

    Switch to Toslink to go through the DAC to the amp, and lose all controls.

    Any ideas why?

    Thanks.
     
  14. macnbits macrumors newbie

    Joined:
    Sep 29, 2012
    #14
    I had the preference pane FunctionFlip installed an forgot about it!
     
  15. refuserefuse, Aug 22, 2013
    Last edited: Aug 22, 2013

    refuserefuse macrumors newbie

    Joined:
    Sep 10, 2009
    #15
    Still not working

    I have tried everything above with the exception that the bash kill lines did not work for me. Said command not found. I find some solution by playing with plugging and unplugging headphones. The volume becomes unstuck in the sense that I can see it go up and down when I press the button. But no sound, no chirps when I press the volume, nothing, headphones or otherwise. So this is no functional improvement. And it becomes stuck again from plugging or unplugging head phones or even from pressing the mute button which in pressed instead of showing the normal x out and zero volume shows maxed volume with the smaller x'd out circle underneath. One time it switched just from me holding down the volume down button. No red led for me and sound output confirms internal speakers.

    Help please

    Maybe related: I was watching a preview on movie phone. Streaming videos of any kind now wont buffer fully. The start then get stuck.
     
  16. rjbeeth macrumors newbie

    Joined:
    Aug 10, 2013
    #16
    Plugging the d***ed phone jack in and out just caused blisters, regardless of the number or times or timing of it all. What did work was killing off core audio's process ID (which obviously respawns). 10 seconds after the kill all was well - thanks!
     

Share This Page