Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

10.8.1 BUG: dock disappears

stiwi

macrumors regular
Original poster
Nov 13, 2010
246
26
Singapore
Steps to reproduce this bug:
1. Open Gmail in Safari's full screen mode
2. Download a PDF attachment
3. Preview will open automatically downloaded file and the dock will disappear

The issue seems to be related with moving between spaces while opening an app. Dock will not re-appear until we hide / unhide it in preferences or until we swipe to another space and swipe back. This happens regardless of the position of the dock.

FYI: my rMBP came with ML pre-installed.

Edit: this issue obviously doesn't happen if we disable Safari from opening safe files automatically.
 

.Pete.

macrumors newbie
Jan 8, 2012
12
0
I´ve had this when downloading files - I normally have the dock hidden, and when you click to download a file, the little animation of the download moving to the downloads folder is triggered, except when the dock appears it is completely blank.

However, let it automatically hide, and then make it reappear, and everything is fine.....:confused:
 
Comment

stiwi

macrumors regular
Original poster
Nov 13, 2010
246
26
Singapore
I´ve had this when downloading files - I normally have the dock hidden, and when you click to download a file, the little animation of the download moving to the downloads folder is triggered, except when the dock appears it is completely blank.

However, let it automatically hide, and then make it reappear, and everything is fine.....:confused:

Well, it is certainly not fine as long as it remains working like that. Also not everyone hide their dock by default.

The best solution for now is to make safari not opening downloaded files by default, certainly less irritating than disappearing dock.
 
Comment

JS77

macrumors regular
Jun 18, 2008
231
2
Just had this happen to me on my rMBP... how does something like this get through QA??
 
Comment

Seamaster

macrumors 65816
Feb 24, 2003
1,083
126
Yup, I've started noticing this. Got to be a .1 issue, as I never saw it previously in ML.
 
Comment

freedevil

macrumors 6502a
Mar 7, 2007
817
1
Yes, I posted about this too and it happens often to me. It is a bug and not specific to a model but the OS
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.