10.8.2 @icloud.com

Discussion in 'OS X Mountain Lion (10.8)' started by NestorRd, Sep 21, 2012.

  1. NestorRd macrumors newbie

    Sep 19, 2012
    With the new update to 10.8.2, one of the features enabled was support for @icloud.com email addresses. I took a screenshot to highlight this, view it here.

    Now, I personally am not sure how the transition to the new standard is going to work out, and I've been chatting with several people who are in the same boat. Currently, if you log in to the icloud.com portal and try to create a new alias off your main iCloud account (which will most likely be a @me.com one), you should only get the ability to make that alias carry the @icloud.com domain, which tells me that from now on every new user who signs up for iCloud will be able to register an email account that will end in @icloud.com with no other option. This is good, and it's the way Apple has done these changes. However, I am having issues finishing the process of setting up any new alias, and here's another screenshot for that. For the last day, this has been the case and the problem has repeated itself constantly.

    Supposedly, everyone with a @me.com address would be able to get the equivalent ending in @icloud.com with the move to 10.8.2 and iOS 6, respectively, but maybe right now it's too early and that's why a lot of people—including myself—are seeing this little problem. What do you think? Are any of you here having the same issue?

    I may point out as well, that the issue in question seems to happen only when a user with a @me.com address attempts to create an alias that will carry the new @icloud.com domain. To confirm this, I went ahead and created an Apple ID ending in @icloud.com and I did not encounter any issues whatsoever; the account is now up and running.
  2. nyolc8 macrumors regular

    Jul 20, 2012
    Same problem here. I have a @me.com address too. And the same error message appears when I want to make an @icloud.com alias.
  3. krspkbl macrumors 6502


    Jul 20, 2012
    Can I just ask, are you only getting errors when you try creating an alias with the same name?

    For example, say your @me address was nestorrd@me.com and you tried creating nestorrd@icloud.com. Is it only happening when you try that or is when you try create ANY alias? I haven't tried it out.

    Anyway, if it is just happening when you use the same prefix as you have for your @me address then it's because Apple has reserved that prefix for your @icloud address. Not everyone can access their @icloud yet but Apple is rolling it out over the coming weeks.

    Take a look at this link: http://support.apple.com/kb/HT5441?v...S&locale=en_US

    Should answer some of your questions :D
  4. nyolc8 macrumors regular

    Jul 20, 2012
    Tried with same name and tried with completely different name. Same error appears.
  5. aarmstrong27 macrumors regular

    Jun 20, 2012
    My @icloud.com alias is there already

    I just looked in mail on my MBA and it already lists my @icloud.com alias (same prefix as my @me.com) and I did nothing to set it up.

    "It just works." As Apple so eloquently puts it.....often. :)

    Attached Files:

  6. NestorRd thread starter macrumors newbie

    Sep 19, 2012
    This article is indeed helpful. Thank you for that.

    However, for me the error still shows up no matter what kind of name I assign to my alias. But as that article itself mentions, the new @icloud.com should be in everyone's hands over the coming weeks.
  7. Jenni8 macrumors member

    Apr 27, 2011
    Well I have a @me email and I don't have the @iCloud alias show up. Although I already have the max 3 aliases set up, so not sure if that makes a difference.


    I read that article above and it looks like my @icloud email address just hasn't rolled out for me yet. Not too worried as I do like my @me address. Nice and short and sweet.
  8. nyolc8 macrumors regular

    Jul 20, 2012
    I only have the @me.com mail address there.
  9. dcorban macrumors 6502a


    Oct 29, 2007
    I checked my mail accounts, and it only lists @me and @mac.

Share This Page