10.9.2 breaks samba3

Discussion in 'OS X Mavericks (10.9)' started by skallal, Mar 8, 2014.

  1. skallal macrumors member

    Joined:
    Aug 24, 2012
    #1
    I've been using a mid 2010 Mac Mini as an SMB file server. It took me a while to realize the built in SMB didn't work with a Windows client. So I tried samba3 from MacPorts. Everything was working, but when I did the Mavericks 10.9.2 update, samba3 hasn't worked right since.

    I had it working yesterday, but decided to reboot the Mini to see if samba3 would still work, and it did NOT. Apparently there are some settings that were temporarily enabled, but lost on reboot. I left File Sharing turned on in Preferences, but unchecked SMB under options.

    I am beside myself, and really would like to get SMB working again with MacPorts samba3. I could describe all of the steps I've tried, including the configuration. But I'd rather see what insight other forum members might have first.
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    I know with 10.9 Apple updated SMB and perhaps they're tweaking that further with 10.9.2, or at the very least updated a component that samba3 needs.

    Did you see what other samab3 users are saying or their support page. I don't use it so unfortunately the only advice I can give is to downgrade your Mac Mini to a version that you know works.
     
  3. skallal thread starter macrumors member

    Joined:
    Aug 24, 2012
    #3
    I managed to get it working by switching from MacPorts samba3 to SMBUp. The latter includes the functionality to install samba3. I prefer to stick with MacPorts, but I need something that actually works. The MacPorts version requires terminal wizardry to setup, while SMBUp uses the GUI.

    Bottom line: Apple has broken SMB which means I cannot access a network share hosted a Mac from a Windows box. I prefer my old Mac mini because it has low-power drain and I can leave it on 24/7. Also it handles my 3TB drive, where Windows is limited to 2TB. And it makes a nice box for Plex Media Server. For most other uses, it is woefully underpowered.
     
  4. Corpi macrumors newbie

    Joined:
    Mar 21, 2014
    #4
    Hi Skallal,
    I have the same problem since I have upgraded to 10.9.2.
    Have you found any solution other than downgrading your system?
     
  5. Corpi macrumors newbie

    Joined:
    Mar 21, 2014
    #5
    For those who are blocked with Samba as I was since 10.9.1 was upgraded to 10.9.2: go to the fire-wall options in the system set up and authorize incoming connections for smbd and nmbd. The system updating deselects these services. However, the use of SMBup is still needed. If this will help!:eek:
     

Share This Page