10.9.2 no wifi hardware installed

Discussion in 'OS X Mavericks (10.9)' started by Jantelagen, Feb 26, 2014.

  1. Jantelagen macrumors regular

    Jantelagen

    Joined:
    Aug 4, 2010
    #1
    I've had some connection problems with my MacBook Air 13" 2011 before, specifically with my home network. One of the fixes I attempted was upgrading to 10.9.2 beta 4, which made my AirPort card lose it completely - my wifi icon said "No hardware installed" and System Profiler could not recognize the card whatsoever. So I did a Time Machine restore to 10.9.1, and it got the card back up, but with slow connections. A week ago I changed my router from a Belkin N router to a D-Link DIR-635, and speeds shot back up.

    Fast forward to this morning, when I updated to 10.9.2 to get the SSL patch and FaceTime Audio. Now my wifi says "No hardware installed" again, and System Profiler doesn't recognize my card again. I tried holding CMD+R and download a fresh copy of Mavericks, and this is possible since wifi works under this mode and can connect to my network. It hangs during the download though, sometimes downloading a little bit with ridiculous time estimates (5 hours) before conking out, sometimes not even getting the connection to start. Every time I have to input my Apple ID 2 times as if it loses the connection to App Store servers almost directly.

    I also tried holding D at startup to run a hardware diagnostic but for some reason, wifi works, but can't find my network, only my surrounding networks.

    What should I do now? I'm writing this on the MacBook Air connected through a clunky D-Link USB adapter, and am downloading Mavericks trough my iMac to make an installer USB from. But what if I had already sold my iMac which I am trying to do? I'd be up **** creek without a paddle I imagine, because I bought this MacBook off of the swedish equivalent of Craigslist with only a seller contract, no original receipt, and as it's bought in the USA sometime during 2011-2012 my warranty will likely have run out. I'm gonna reinstall, but maybe I should take my chances and go to my nearby Apple Store? I'm just wondering if anyone else has this problem, and if the Apple Store is going to charge me tons of money just to look at my Mac.
     
  2. Jantelagen thread starter macrumors regular

    Jantelagen

    Joined:
    Aug 4, 2010
    #2
    Well, for posterity, I'll tell you that it worked. A reinstall of Mavericks from USB, made with createinstallmedia through Terminal, and at boot I restored my MacBook from Time Machine. Wifi is now working at acceptable speeds, and the Mac is running 10.9.2 (confirmed by running gotofail in Safari, too)
     
  3. MiWall81 macrumors member

    Joined:
    Jul 17, 2011
    #3
    Same problem here. Just updated to the 10.9.2 and no wifi hardware... Figured I'd update before heading out to read up on a few articles at the coffee shop and no no damn internet. What a joke of an update. I'm ticked... Why is this update still available if it's such crap? Figure it out apple. Geez.
     
  4. powers74 macrumors 68000

    powers74

    Joined:
    Aug 18, 2008
    Location:
    At the bend in the river
    #4
    Didn't think it was the hardware.

    Yep, same issue here. Fortunately I'm on a MacPro so I'm wired in with Ethernet. I can just wait for a fix. I feel bad for you guys with MacBooks. :(
     

Share This Page