10.9.4: Quicklook and Preview.app do NOT work for PDFs

Discussion in 'Mac Basics and Help' started by Maniamac, Jul 8, 2014.

  1. Maniamac macrumors member

    Joined:
    Oct 31, 2007
    #1
    Hello,

    I'm running 10.9.4 on a Early 2013 Retina MacBook Pro.

    I can not view PDFs using Quicklook or Preview.app (though all other supported file types work fine). The file's icon is just a blank sheet. When I hit spacebar on it, a small window appears with that blank icon, the file name, and file size. If I double-click the file, Preview.app opens but displays NOTHING. Furthermore, if I try to open the file within Preview.app using File>Open, all PDFs are greyed out.

    I had Adobe Reader installed, which has no problem opening these files. Wondering if there was a possible conflict, I used CleanMyMac 2 to uninstall Adobe Reader, but that did not help. If I go to "Get Info" on a PDF and delete the .pdf from the filename, Preview will open the file, though Quicklook still does not work.

    I've tried many things to troubleshoot, including:

    1) Going to "Get Info" and making Preview.app the default PDF reader. Adobe Reader initially was, and I noticed that when trying to change it to Preview.app, it was not listed as recommended application, so I had to select it instead from "All Applications". Believing Adobe Reader was trying to hijack all my PDF reading, I then went about...
    2) ...Deleting Adobe Reader.
    3) Repairing permissions
    4) Rebuilding the launchservices database
    5) When double-clicking a PDF file, I closely watched Console. I noticed a message reported by gkbisd that the cdhash could not be collected for QuicklookUIHelper and Preview.app. Believing gkbisd to be related to Gatekeeper, I changed my Mac's security setting to allow "All Applications." It didn't work. But it made me...
    6) ...Wonder if the OS was glitching out, so I installed the 10.9.4 Combo Update. It resolved the Console messages reported by gkbisd, but not the problem itself. I couldn't see any other suspicious messages in Console.
    7) I booted into Safe Mode. Here's where I'm perplexed. I immediately went to a PDF file in Finder in Safe Mode and sure enough, Quicklook and Preview.app both worked. After about 20-30 seconds, though, the problem reared its head again. And what's more, shortly thereafter, I found myself logged out (I don't know if that's related). I saw nothing suspicious in Console until I was logged out.

    I have no idea what's going on. I appreciate your help.
     
  2. bratman91 macrumors newbie

    Joined:
    Jan 26, 2013
    #2
    gkbisd error

    Quite a number of people have reported having the same errors in Console as you, and it doesn't seem to be exclusive to any particular app. When opening most, if not all of my apps, I get a series of error messages similar to these:

    15/07/2014 11:53:50.079 gkbisd[14670]: Unable to collect cdhash for /Applications/Notes.app (error code 100024)
    15/07/2014 11:53:50.201 com.apple.SecurityServer[14]: Killing auth hosts
    15/07/2014 11:53:50.201 com.apple.SecurityServer[14]: Session 100072 destroyed
    15/07/2014 11:53:50.203 com.apple.SecurityServer[14]: Session 100073 created

    Take a look at this thread - a possible solution was offered but, with time, it seems that it did not resolve the issue.

    https://discussions.apple.com/message/26243739#26243739
     
  3. Maniamac thread starter macrumors member

    Joined:
    Oct 31, 2007
    #3
    Thanks so much for replying. I now realize that those Console errors are spit out even when an app is apparently functioning properly, so they probably aren't related to my PDF-viewing problem.

    I ended up reinstalling Mavericks, which unfortunately did not do the trick. I think that the key lies in the fact that in Safe Mode, Quicklook and Preview.app work correctly for PDFs...but only for about thirty seconds. I guess an app or process is launching at the time and causing this problem. Disabling all of my login items doesn't help, so sniffing out the troublemaker probably will be very difficult and time-consuming.

    I'm expecting that an Erase and Install is in order, which I was hoping to avoid, since I wouldn't be able to restore my apps from my backup (at least not the ones that don't install completely simply by dropping into the Applications folder)--so I'd have a lot of apps to re-download. Instances like these make me kind of wish that Migration Assistant wasn't "all or nothing."

    In any case, I have a ticket filed with AppleCare, and I'm expecting to hear back from engineering by the end of the week. Apple's been helpful, as usual. I'm hoping that they could come up with a better solution for me.

    Thanks again for the help!

    Much respect,

    Maniamac
     

Share This Page