10.9 and Handbrake (low CPU usage)

Discussion in 'OS X Mavericks (10.9)' started by CTYankee, Oct 30, 2013.

  1. CTYankee, Oct 30, 2013
    Last edited: Oct 30, 2013

    CTYankee macrumors 6502

    Joined:
    Jul 18, 2002
    #1
    I noticed Handbrake was encoding at about 75% its usual rate. I checked Activity Monitor and saw that it is only using 60% CPU.

    On 10.8 it would definitely run faster and hotter. The fan barely kicks on now. Rendering is at 60fps and not the 75+ for the AppleTV2 setting with 720P source material.

    Anyone else seeing Handbrake run slower?
    Any settings I'm missing that are make it run cooler/slower?
     
  2. Manic Harmonic macrumors 6502

    Joined:
    Dec 4, 2011
    #2
    I don't know if handbrake supports app nap yet, but have you checked get into to see if it supports it, and if so, if it's enabled? Just a bunch because it sounds vaguely similar to problems people have been having with FCP X.
     
  3. pastrychef macrumors 601

    pastrychef

    Joined:
    Sep 15, 2006
    Location:
    New York City, NY
    #3
    Try this:

    1. Right-click Handbrake in your Applications folder.
    2. Select Get Info.
    3. Put a check next to Prevent App Nap.
     

    Attached Files:

  4. nxent macrumors 6502

    Joined:
    Nov 7, 2004
    Location:
    seattle
    #4
    you got handbrake to work with 10.9? my copy crashes everytime i launch it.
     
  5. jostermacedo macrumors newbie

    Joined:
    Nov 2, 2013
    #5
    nxent,

    here Handbrake works flawlessly in Mavericks. Which version are you using? I suggest you to download the latest nightly build at:

    http://handbrake.fr/nightly.php

    Joster
     
  6. CTYankee thread starter macrumors 6502

    Joined:
    Jul 18, 2002
    #6
    I restarted and it worked fine. However good tip on the ability to turn off App Nap, thanks!
     
  7. RedRaven571 macrumors 65816

    RedRaven571

    Joined:
    Mar 13, 2009
    Location:
    Pennsylvania
    #7
    Yes, thanks Pastrychef; running much better with app nap disabled....
     
  8. CTYankee thread starter macrumors 6502

    Joined:
    Jul 18, 2002
    #8
    Strange…HB occassionly starts and runs around 40-60% of CPU. Other times t cranks right up to 98%. I can't see why or what is different, but it definitely does not go full speed all the time like it used to (even with App Nap turned off).
     
  9. Mr. Retrofire macrumors 601

    Mr. Retrofire

    Joined:
    Mar 2, 2010
    Location:
    www.emiliana.cl/en
    #9
    The reason is probably the new timer coalescing. Threads sleep and wake up, as necessary. OS X uses high precision timers for the thread (pthreads, GCD and so on) management, AFAIK.
     
  10. nxent macrumors 6502

    Joined:
    Nov 7, 2004
    Location:
    seattle
    #10
    Yep, I got it working. It had to do with the hardware I was running 10.9 on-
     

Share This Page