10.9 Crashed: OS X USB Bootable in Windows

Discussion in 'OS X Mavericks (10.9)' started by rotter2142, Mar 27, 2014.

  1. rotter2142 macrumors newbie

    Joined:
    Nov 9, 2011
    #1
    Hey!

    My OS X 10.9.2 crashed recently and since then I am unable to boot into the OS X partition.

    Since, I have Windows installed through Bootcamp, I can boot up into Windows.
    I can also access the files stored in the Mac partition, that means the HDD is not a problem, and its a problem with the OS X System Files; thus requiring a system repair.

    As I do not have a Recovery Partition installed and DVD drive is not working, I cannot go repair through that route.

    I installed Transmac and downloaded a Bootable DMG image of 10.9.2 Build (13C64) and restored the image in a 16GB pendrive. The problem here is that while the USB is read at startup, while loading there is a Prohibited sign coming up.

    So i figured there must be something wrong with the image I used for the restore.

    I downloaded another copy of OS X, this time a 10.9.1 (Mac App Store) version and restored the InstallESD.dmg on the USB through Transmac. This time the USB fails to show up even at boot time (when I press option key).

    There is no one with a Mac nearby with which I can troubleshoot, and no disc of SL or any other version. Getting the OS from torrents is my only source.

    PS: My USB is in GPT partition.

    Please help me out, I am trying to make this right since the past 4 days without any luck!!
     
  2. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #2
    I'm not totally clued up on Bootcamped systems, but could you use Internet recovery on the damaged OSX installation? Yes, you will lose data if you perform a clean install but if you just install a copy over the top of the existing OSX partition, I think you're data should be safe.

    As always, back up first!
     
  3. rotter2142 thread starter macrumors newbie

    Joined:
    Nov 9, 2011
    #3
    I solved the issue of getting a working USB Bootable.

    But now I am in a more terrible predicament!

    I have a 2009 Macbook Pro 13 running on a fairly new 1TB WD HDD.

    I have a 65GB partition tucked away for Windows through Bootcamp and the rest is running Mavericks 10.9.2. No Recovery partition here as I upgraded directly from SL.

    The problem here is now that I can't format the main partition nor can I log into OS X; i can though log into Windows and it runs perfectly fine while also allowing me to access the files stored on the HFS+ volume.

    Repairing/Unmounting/Fromatting (by force too) the disk fails (through Disk Utility or the command line diskutil, accessed by booting through a bootable OS X 10.9.1 USB).

    I also tried the diskpart tool in Windows to delete the HFS partition, but that fails too!

    What do I do next?
     
  4. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #4
    Are you trying to wipe the drive? If so, simply select the physical drive (NOT the VOLUME) in Disk Utility on the USB and erase it. As a note, only 10.7 and 10.8 could have the install ESD restored. Mavericks requires Lion Disk Maker X.
     
  5. rotter2142, Mar 27, 2014
    Last edited: Mar 27, 2014

    rotter2142 thread starter macrumors newbie

    Joined:
    Nov 9, 2011
    #5
    I tried that but it didnt work. The partition problem has been solved though. I booted into Windows through the working Bootcamp partition, loaded up its Disk Manager and deleted the Mac HD volume from there. Strange that it works through GUI but not through the command prompt diskpart utility.


    Though I have run into ine more hurdle, I booted through the pen drive and it seems that it cannot launch the Install OS X part. Disk Utility, Restore through Time Machine etc. works but not the Install OS X option. Pressing continue doesn't seem to do anything. I checked the log and it says OS X Utilities: launch application not accessible (384:303), how do I solve this? Is this a read write permission issue? Which particular file is this related to?

    localhost unknown [369]: OS X Utilities [384:303] Could not launch application. Exception: launch path not accessible.

    This is the error as seen in the Installer Log when I click COntinue for Install OS X.

    Creating a new bootable USB did not help too. WOrking on a Mac App Store copy of 10.9.2.

    Thank you for your patience in reading these long stories.
     
  6. rotter2142 thread starter macrumors newbie

    Joined:
    Nov 9, 2011
    #6
    I ran into the problem again. And I have found a very simple solution to this!

    If ever the Mac partition fails, just log into the windows partition, go to disk manager and just delete the hfs volume! Do not erase it. Restart your machine and your HFS volume should be just fine!

    That means windows is somehow messing the HFS volume up. Anyone know why this is happening? This is quite a common issue with systems that have mavericks and windows installed!
     

Share This Page