10.9 Exchange not updating?

Discussion in 'OS X Mavericks (10.9)' started by m0bus, Jul 12, 2013.

  1. m0bus macrumors newbie

    Joined:
    May 26, 2011
    #1
    Noticed this around DP2 and it's become a real problem in DP3 but using Exchange mail servers Mail just stops syncing entirely. Doing a Rebuild will fetch me emails up to about a year ago and clearing the Caches directory for Mail seemed to alleviate the issue until Mail was closed and re-opened and then it stopped updating. Activity window shows it's updating and requesting for the account but for all intensive purposes the account is dead in Mail - works fine in web Outlook.

    Anyone else having this issue with their mailboxes just ceasing to update?
     
  2. mwhities macrumors 6502a

    Joined:
    Jul 13, 2011
    Location:
    Mississippi
    #2
    No answer yet but, I just upgraded to DP3 myself last night and will be adding my Exchange account in just a few.

    Are you using Mail or Outlook or? I'll be using Outlook if that helps. (I guess I could throw it into Mail too if that's what you are using.)
     
  3. m0bus thread starter macrumors newbie

    Joined:
    May 26, 2011
    #3
    Hmmm... so just popped all my info into Outlook on OSX and it's working just fine. Wondering if something has changed in the Autodiscover area or something but I'm getting instant email updates in Outlook whereas Mail.app hasn't synced a single thing since I wiped out the Caches last night even after a full Rebuild, removal and re-addition of account and everything.
     
  4. mwhities macrumors 6502a

    Joined:
    Jul 13, 2011
    Location:
    Mississippi
    #4
    I opened up Outlook and it Autodiscovered all of my info. All I had to do was type the password in.

    Would you like m to test in Mail?
     
  5. m0bus thread starter macrumors newbie

    Joined:
    May 26, 2011
    #5
    If you can that would be great - I had the exact same thing with Outlook where it just worked automatically but Mail is still being problematic.

    Odd but it seems that Outlook is now suffering the same non-updating behaviour.
     
  6. mwhities macrumors 6502a

    Joined:
    Jul 13, 2011
    Location:
    Mississippi
    #6
    I added Exchange to Mail and I had to type in all of the info.

    After adding it, I noticed the most recent email was from 05/6/2013... Strange. I had to connect to the Exchange server and it downloaded more emails but, nothing newer.

    So I closed out and opened it again. Still nothing. I restarted the system and opened Mail, it started downloading the newer emails up until today.

    I'll keep it open as well as Outlook and see if it updates as well. Outlook is running properly thus far.
     
  7. m0bus thread starter macrumors newbie

    Joined:
    May 26, 2011
    #7
    Ok so it's not just me. I'll put in a radar bug and then post the bug # back here for reference in case anyone else hits the issue and wants to push the bug up on Apple's system. Thanks for taking the time to set this up and test on your end!
     
  8. GaresTaylan macrumors 6502a

    Joined:
    Nov 11, 2009
    #8
    My Outlook works fine, but in Mail its a different story. In DP2 I was no longer able to get email (I could in DP1). In DP3, I can get exchange mail again, but if I go to delete email it tells me the emails can't be deleted.
     
  9. m0bus thread starter macrumors newbie

    Joined:
    May 26, 2011
    #9
    Radar seems to be having a few issues so I've not been able to log this but I'll add the extra information about Outlook vs Mail to make sure they're fully aware of the problems. Thanks again for the additional info!
     
  10. mikecwest macrumors 6502a

    mikecwest

    Joined:
    Jul 7, 2013
    #10
    exchange on mavericks

    I used to use an exchange server on SL, it was an EAS. It appears that something in Lion broke, (or fixed depending on how you look at it) the ability to use EAS only servers.

    If you were upgrading from SL to Mavricks, then that may be your issue.

    If you have issues connected to EAS through Apple Mail, for what ever reason, you should check out DAVmail. Its free, and works well if you follow directions. Its not perfect, sometimes you have to restart to get it syncing again.

    I did not write or develop DAVmail, I am merely a user, so this is not an advertisement!
     
  11. j_maddison macrumors 6502a

    j_maddison

    Joined:
    Mar 31, 2003
    Location:
    Nelson, Wales
    #11
    I've now found that Exchange support is working fine in the latest build of Mavericks. Previously I could only get it to work through the Outlook app, but as of yesterday it works (when connected to the VPN) for Mail and Calendar integration too (Apple apps).

    So far I've had no issues with it. It did take a couple of attempts for it to auto configure, but once it did it's ran perfectly.

    ----------

    I've now found that Exchange now syncs with Apple Mail and Calendar, where previously it didn't work at all. It's always worked for me when using the Outlook app.

    I have to be connected to the corporate network, either directly or via a VPN for it to work, but this was always the case for me.
     
  12. craigd macrumors 6502

    Joined:
    Jul 24, 2007
    Location:
    perth, AU
    #12
    This was a deal breaker for me as well.

    I have also now noticed it is working fine.

    Great news


     
  13. j_maddison macrumors 6502a

    j_maddison

    Joined:
    Mar 31, 2003
    Location:
    Nelson, Wales
    #13
    I can't find anything for Proxy support, so I'm guessing that functionality is not on the agenda. It would be nice not having to log onto the VPN to send and receive mail, but something is better than nothing!
     
  14. sliceoftoast macrumors 6502

    sliceoftoast

    Joined:
    Mar 3, 2012
    Location:
    In a Toaster
    #14
    This is also happening in the GM. Exchange account not updating. Either is the Microsoft Lync Client.
     

Share This Page