10.9: FaceTime and iMessage won't let me sign in

Discussion in 'OS X Mavericks (10.9)' started by peterbaby, Oct 25, 2013.

  1. peterbaby macrumors member

    Joined:
    Jan 29, 2008
    #1
    Hi,

    I have installed the official Mavericks release (update from Lion) on my MB Pro (2011).
    I can't sign in into FaceTime or iMessage (it tries for more than a minute, then I get an error message). Other iCloud functions work perfectly (mail, calendar, docs...).

    Many online proposed fixes date back from Mavericks previews... I tried those unsuccessfully:
    - Changing my iCloud password.
    - Ensuring time and date are automatically set
    - Editing the "hosts" file
    - Changing my DNS to 8.8.8.8
    - Resetting iCloud docs (on iCloud.com)
    - Repairing permissions
    - Connecting from another place (other ISP, router)
    - In iMessage, signing in from "Preferences>Accounts"
    - Signing in with a "@icloud.com" alias (my .mac address is still my iCloud login/Apple ID).

    NONE of the above worked :(

    Any idea will be welcome!
     
  2. vtstarck macrumors regular

    Joined:
    Jun 16, 2009
    #2
  3. peterbaby thread starter macrumors member

    Joined:
    Jan 29, 2008
    #3
  4. peterbaby, Oct 26, 2013
    Last edited: Nov 2, 2013

    peterbaby thread starter macrumors member

    Joined:
    Jan 29, 2008
    #4
    Well, maybe there is an explanation here:
    https://discussions.apple.com/message/1219096#1219096

    For some people, it seems to be related to the absence of the computer serial number in the "about my mac" section.
    I am exactly in this case: my motherboard was exchanged by an Apple Reseller 2 years ago. Since then, the serial nr of the motherboard never appeared. I thought: ah well, doesn't matter.
    But maybe this causes an authentication issue now...

    Are you in the same situation Vtstarck?

    EDIT November 2nd:
    I did go to an Apple Care center, asked the guy to correctly set my logic board serial # (it takes 2 minute for them). He did (unwillingly), and guess what: problem solved, FaceTime and iMessage are now working perfectly.
     

Share This Page