10 Minute Boot Time in Lion on i7 Mini

Discussion in 'Mac OS X Lion (10.7)' started by chris-sirhc, Aug 10, 2011.

  1. chris-sirhc macrumors newbie

    Joined:
    Aug 10, 2011
    #1
    My new i7, dual HDD Mini Server takes 10 minutes to boot from power off to login screen. Is there a fix for this?

    I recall it booted fast on the first boot, but once I started installing softeware (Aperture, Office and a few other stable bit of productivity software that I have successfully used on my Snow Leopard Macbook), the boot time shot up to 9 and 11 minutes from start button to login screen. I timed my last few bootups to get an exact number.

    The machine seems to operate normally.

    I repaired disc permissions on the startup HDD and the boot time didn't really change, 9 minutes. A SMC reset did not have any effect either. PRAM, too. And I deleted the Caches from my ~/Library folder. Nothing seems odd in the Activity Monitor, either. I all I can think of, given I am not a super linux nerd or know too much super advanced stuff under the hood.

    Is this a problem with Lion? The hardware? Or some Lion Server issue? A search here, asking on the Apple support forums, and google did not give direct answers to this problem. I'd hate to have to actually take this to a Genius Bar and get the run-around there. Any diagnostic tests, simple flushes and checks? Ideas?!?
     
  2. Kenc1103 macrumors member

    Joined:
    Aug 3, 2011
    Location:
    Fremont, CA
    #2
    10 minutes to boot up is a real long time. My i7 mini server in RAID0 takes about a minute to boot up and I thought it's long already because it hangs at the beginning to try to look for the startup disk which I have talked to Apple support over the phone for an hour and still not able to resolve.
     
  3. Quad5Ny macrumors 6502a

    Quad5Ny

    Joined:
    Sep 13, 2009
    Location:
    New York, USA
    #3
    Hold Command-V for a few seconds right before the Apple logo during boot and post back the lines before, during & after it does the 10min delay.

    http://support.apple.com/kb/ht1492
     
  4. chris-sirhc, Aug 11, 2011
    Last edited by a moderator: Aug 12, 2011

    chris-sirhc thread starter macrumors newbie

    Joined:
    Aug 10, 2011
    #4
    OK, started up in verbose mode and took pictures of the text as is scrolled by before the blue screen came up. Attached is the login text and the shutdown text. On the login, I forgot to grab two lines from one startup but grabbed it from privies login. I can't recall if they were identical, but I suspect they were as they looked the same size and it was only two lines. This didn't take too long, maybe a minute and then there was 9 more of waiting...

    If anyone has any ideas, I'd be tickled. I am pretty clueless as to what this exactly means nor am I able to identify any specific problems from this. SO, if no solution here, it is off to the Genius Bar...

    OK! Got it working. Tried the same stuff again and it seemed to take. Not sure why, but glad I don't have to deal with it for the time being.

    I did the following:
    Repaired Disc Permissions for the startup drive.
    Deleted /Library/Caches
    Reset the SMC
    Reset the PRAM

    Hopefully this will help others. From the various threads, it could be hit or miss. I can only assume that 10.7.1 will take care of some of this.

    OK, again. It seems there is an issue with a USB connection. When an external drive is plugged in to either of two USB ports (I only tested two so far) and is OFF, it takes 10 minutes to boot. If it is ON, it takes about a minute, which is the same without this cable plugged into the port.

    A USB cable (same brand) plugged into a printer that is off does not seem to affect startup performance.

    And, finally... If you turn the drive on during the 10-minute wait, the machine immediately goes to the login screen. Clearly knows/remembering there is a drive and waits for it.
     

    Attached Files:

  5. AndrewS macrumors member

    Joined:
    Jul 16, 2002
    Location:
    Bourbon Country
    #5
    Try going to system settings/startup with all your USB drives plugged in and selecting the minis built in drive as the startup drive and see if that does it.
     
  6. chris-sirhc, Aug 12, 2011
    Last edited: Aug 19, 2011

    chris-sirhc thread starter macrumors newbie

    Joined:
    Aug 10, 2011
    #6
    THe external drive does not show up in that window, only the main HD of the machine. Earlier I had selected it and restarted to be sure. But, there was no noticeable change, in performance or appearance.

    EDIT:
    And, it looks like the 10.7.1 updated cured whatever problem it exactly was. Better late than out of the box.
     

Share This Page