1080p on rMBP

Discussion in 'MacBook Pro' started by kanesw, Jul 13, 2012.

  1. kanesw macrumors regular

    kanesw

    Joined:
    Dec 29, 2011
    Location:
    Nottingham
    #1
    Ive been trying to play 1080p trailers via Youtube on my rMBP but it seems to struggle to stream and render them. They stutter back and forth for the whole duration.

    Im running Safari on OSX GM and Ive got my resolution set to in between Best for Retina and More space.

    Any one else having problems playing HD content?
     
  2. charlieegan3 macrumors 68020

    charlieegan3

    Joined:
    Feb 16, 2012
    Location:
    U.K
    #2
  3. AlexBass macrumors regular

    Joined:
    Jul 9, 2012
    #3
    I think it's just a problem with youtube. My ordinary macbook pro often comes across the same issues when playing 480p and 720p.
     
  4. kanesw thread starter macrumors regular

    kanesw

    Joined:
    Dec 29, 2011
    Location:
    Nottingham
    #4
    Tried a few more videos and the problem is non existent. Now if we could watch 4k please!
     
  5. Dangerous Theory macrumors 68000

    Joined:
    Jul 28, 2011
    Location:
    UK
    #5
    Have you tried using the HTML player instead? Flash is a disaster.

    Also, if you download gfxcardstatus, it tells you if you're running the integrated graphics or the 650M.
     
  6. 01mggt macrumors 6502

    Joined:
    Jun 23, 2010
    #6
    There is the TimeScapes video on youtube that I think was shot in 4k. Just select the original resolution that's listed above 1080p. Sadly you can still see some signs of the compression on youtube. On youtube it also doesn't seem to have a really smooth framerate.
     
  7. itsalan macrumors newbie

    Joined:
    Feb 5, 2008
    #7
    I ran into this problem on both my rMBP and iMac (both on 10.8), and the problem seems to be only in safari, as chrome seems to play the video fine. I made the following changes and the videos seem to be working in safari so far:

    -in safari prefs, go to advanced and enable "show develop menu in menu bar"
    -in the develop menu, enable webGL
     
  8. stevedusa macrumors regular

    Joined:
    Jun 12, 2012
    #8
    I was playing a rendered 2K footage (in H.264) via VLC 2 which supports Retina support. Smooth as a butter and talk about crisp clean...
     
  9. eagandale4114 macrumors 65816

    eagandale4114

    Joined:
    May 20, 2011
    #9
    Download and install click to flash safari extension.
    Then go to www.youtube.com/html5 and make sure that you are NOT in the trial.
    You should see QuickTime taking over the video playback. As an added bonus you can right click and download videos with the use of additional software.
     
  10. Zwhaler macrumors 603

    Zwhaler

    Joined:
    Jun 10, 2006
    #10
  11. photosaurus macrumors regular

    Joined:
    Jun 22, 2012
    #11
    Click to flash isn't going to work on the new Safari versions, i.e. the retina. However, Click To plugin works brilliantly.
     
  12. Dangerous Theory macrumors 68000

    Joined:
    Jul 28, 2011
    Location:
    UK
    #12
    How come you shouldn't use the HTML5 trial?
     
  13. photosaurus macrumors regular

    Joined:
    Jun 22, 2012
    #13
    The pug in only override flash, not HTML5... so to download and play in Quicktime, or use the safari media player (using the plugin).. you need the video's to be flash.
     
  14. korbearus10 macrumors member

    Joined:
    Jun 27, 2012
    Location:
    California
    #14
    Click to Flash is working for me on my retina Safari. Perhaps there's a ML safari?
     
  15. eagandale4114 macrumors 65816

    eagandale4114

    Joined:
    May 20, 2011
    #15
    Google's HTML5 playback viewer is what is causing all the lag. Your retina system should be able to play 4k no problem. My 2011 mbp can. The video player is inefficient or just optimized for playback when using chrome. Disabling googles HTML 5 player will force YouTube to load flash. Click to flash will replace the flash with QuickTime compatible .mov video files that QuickTime will play.
     
  16. photosaurus macrumors regular

    Joined:
    Jun 22, 2012
    #16
    Nope.. but I tried installing it, and it didn't take. Then I found a note on the website stating it wouldn't work in 5.1 or higher, with a link to the Click To plugin as an alternative.
     
  17. eagandale4114 macrumors 65816

    eagandale4114

    Joined:
    May 20, 2011
    #17
    Yes there is a different version of safari for ml. It drops support for webkit based extensions like click to flash. Click to plugin is a broader version of click to flash. You should be able to configure it to replace flash with HTML5. I'll post screenshots later.
     
  18. BlazednSleepy macrumors 6502a

    Joined:
    Apr 15, 2012
    #18
    I have a pretty good internet speed and youtube is always slow. It seems lately its been at its worst. It think its a combonation of flash and youtubes servers. It also varies on videos for me whether it will buffer fast or not.
     
  19. eagandale4114 macrumors 65816

    eagandale4114

    Joined:
    May 20, 2011
    #19
    I have 20 Mbps fios and a blazing fast computer. Try my method. The difference is like night and day.
     
  20. BlazednSleepy macrumors 6502a

    Joined:
    Apr 15, 2012
    #20
    Holy crap your right. I have the same internet speed as you and now the buffering is SO much faster! But reading that it won't work with ML disappoints me lol

    ----------

    I also noticed 4k videos don't look as good with this extension =/

    scratch that I was viewing 4k video that were only shown in 720p lol.
     
  21. eagandale4114, Jul 13, 2012
    Last edited: Jul 13, 2012

    eagandale4114 macrumors 65816

    eagandale4114

    Joined:
    May 20, 2011
    #21
    Guide: How to view youtube videos in Safari without lag. OS X Lion and Mountain Lion compatible.

    For this guide I will be using the timescapes 4k rapture trailer. You will need a mac running OS X Lion or Mountain Lion.

    This is how Timescapes looks with flash player installed.
    Nothing unusual but playback at very high resolutions is takes up a lot of CPU and battery.


    [​IMG]


    Now this is the same video with HTML5. Same UI for the player. At high resolutions the video is just unplayable. Heck at low resolutions it is unplayable.


    [​IMG]


    Now the fix.
    1) Go to the HTML5 youtube trial page here, and make sure you are not in the trial. It should look like this.


    [​IMG]


    2) Download ClickToPlugin and install it.

    3) Go to the "Media Player" page for preferences. Mine looks like this.


    [​IMG]


    I don't have an ATV but if I did I could stream videos to it. (Kinda useless with airplay mirroring in ML.)


    In the "Shortcuts menu" page enable downloads. My page looks like this.
    [​IMG]


    Now lets go back to that timescapes video. This is what it should look like now. Looks familiar? Its quicktime X.


    [​IMG]


    Hovering over the left side will let you choose your resolution if you want to play in anything other then what you set as a default.


    [​IMG]


    Right clicking on the video will also give you the option to download it in whatever format/resolution you are currently playing it in. You can even open it in quicktime X.


    [​IMG]


    Enjoy.:D
     
  22. dkimxd macrumors member

    Joined:
    Aug 11, 2008
  23. eagandale4114 macrumors 65816

    eagandale4114

    Joined:
    May 20, 2011
    #23
    Those are the preferences for clicktoplugin.
    Go to Safari> Preferences> Extensions. Then select ClickToPlugin and open the settings.
     
  24. Pentad macrumors 6502a

    Pentad

    Joined:
    Nov 26, 2003
    Location:
    Indiana
    #24
    Safari has always been crap when doing YouTube stuff. Have you tried FireFox or Chrome? I find Chrome to play YouTube videos exceptionally well.

    Try it out and see!
    -P
     
  25. unibility macrumors 6502

    Joined:
    Apr 6, 2012
    #25
    i bought the TimeScape 2880x1620 a 5.88 GB version and it looks magnificent on the rMBP. i'm thinking about purchasing the 4k version but it's 26GB. :eek:
     

Share This Page