11" MBA July 2011 owners who have issues when waking from sleep

Discussion in 'MacBook Air' started by Esquire1, Sep 5, 2011.

  1. Esquire1 macrumors member

    Joined:
    Jun 4, 2010
    #1
    My 11" 128/4 MBA has issues waking up from sleep sometimes. It'll just hang at a black screen and I'll have to restart.

    Anyone else have the same issue? It seems fairly common: https://discussions.apple.com/thread/3214368?start=0&tstart=0

    Anyone have any solutions they had work for them? Hopefully Apple fixes this in a firmware update. I seriously doubt it's hardware related.
     
  2. Lemsly macrumors newbie

    Joined:
    Aug 16, 2007
    #2
    I think this is an issue with Lion. I get the same problem on my mid 2009 MBP 13".
     
  3. Gunny011 macrumors regular

    Joined:
    Mar 26, 2011
    #3
    I've had no issues...pretty fast when waking up from sleep, 2 seconds at the most.
     
  4. Esquire1 thread starter macrumors member

    Joined:
    Jun 4, 2010
    #4
    Usually, I do not have a problem. However, it does occur every so often. Often enough for me to make a thread about it.
     
  5. NutsNGum macrumors 68030

    NutsNGum

    Joined:
    Jul 30, 2010
    Location:
    Glasgow, Scotland
    #5
    System Preferences > startup disk

    Then click your mac OSX volume, this stopped it happening entirely for me.
     
  6. Gunny011 macrumors regular

    Joined:
    Mar 26, 2011
    #6
    Do you have a lot of apps open when you put it to sleep? This may be why. I wish I had snow leopard to compare the instant on feature with
     
  7. macosx22 macrumors newbie

    Joined:
    Sep 2, 2011
  8. joec1101 macrumors 6502

    Joined:
    Jun 29, 2010
    Location:
    So Cal, USA
    #8
    I had this same problem with my 2011 13" MBA i7/256/4 Lion 10.7.1

    Someone on another forum suggested resetting PRAM, which I did. It seems to be working just fine now - wakes up almost instantly just like it should.
     
  9. Esquire1 thread starter macrumors member

    Joined:
    Jun 4, 2010
    #9
    Thanks. I'm going to give this and PRAM reset a shot.
     
  10. Esquire1 thread starter macrumors member

    Joined:
    Jun 4, 2010
    #10
    Chrome, Mail. That's all. I always wondered if it's Chrome. I'll see what quitting it before sleep will do.
     
  11. Hackfix21 macrumors member

    Joined:
    Jun 1, 2011
    #11
    Am having problems with long wakeup times as well. What does resetting PRAM mean and how do I do it?
     
  12. joec1101 macrumors 6502

    Joined:
    Jun 29, 2010
    Location:
    So Cal, USA
    #12
    Okay, so the next day after resetting the PRAM it started doing it again. I did a little more research and it appears to be an issue with the machine going into Hibernate Mode (not Sleep, but Hibernate).

    Yet another suggestion by someone was to change Hibernate Mode to 0 so the system will not go into Hibernate mode, but will go into Sleep mode only.

    I did try this and it seems to be working OK now.

    I'll report back in a few days to see if the results are still the same.

    Here's links for both PRAM reset and Hibernate Mode change:

    PRAM: http://support.apple.com/kb/ht1379

    Hibernate: http://www.tuaw.com/2011/08/22/why-hibernate-or-safe-sleep-mode-is-no-longer-necessary-in-os/
     
  13. joec1101 macrumors 6502

    Joined:
    Jun 29, 2010
    Location:
    So Cal, USA
    #13
    OK, so after several days now, changing the Hibernate mode to 0 has worked! :D

    It wakes up instantly now every single time - no delay at all...
     

Share This Page