12" 1.33 iBook not getting along with iTouch

Discussion in 'PowerPC Macs' started by shaunymac, Jan 29, 2009.

  1. shaunymac macrumors 6502

    Joined:
    Feb 5, 2008
    #1
    I have a problem here. I posted it in the 'iTouch' forum ,but no one seems to be able to figure out the problem. Before I schedule an appt., I figured I would give it one more shot.

    I, or my parents, have a 12" iBook that they are trying to sync their iTouch too. It has worked in the past but as of now it will not recognize it. It will charge it but not recognize it on the desktop, finder, or in iTunes. However, if I put my iPod, iPhone, external HD on the iBook it shows up. That, to me tells me that the USB ports are good on the iBook.

    Next, the iTouch shows up fine on my MBP as soon as it is plugged in.

    Both the iBook and the MBP are running the the lastest version of leopard (10.5.2?) and the iTouch is at the latest as well (2.2.1.) I can't remember the numbers exactly. Im on a windows and none of this is sitting in front of me. :(

    Anyways, if anyone has any suggestions, please let me know. Thanks

    Oh, the USB ports on the iBook are 2.0 not 1.1. I checked that. Just in case you are wondering.
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    Are you using the same sync cable for the different iPods?
     
  3. shaunymac thread starter macrumors 6502

    Joined:
    Feb 5, 2008
    #3
    I just tried switching the cables and once again, my original nano with its flaky plastic case, according to some, pops right up. Oh, and that iTouch, yeah it is nowhere to be found. Not in the finder, desktop, or itunes. Only when I go to my intel macs does it show. :confused:

    This would be a ok with me if it was mine but it's not. They only have PPC. If apple is trying to weed out PPC this quick then there is going to be a serious problem. Maybe my nano works because it was from that generation.:D

    Looks like I have a trip to the apple store in store for me. Crap.

    Thanks for your advice/help/suggestions.
     
  4. shaunymac thread starter macrumors 6502

    Joined:
    Feb 5, 2008
    #4
    Ok guys, I just got back from the genius bar, well last night. I told them everything I tried and they too seemed a little puzzled. The first genius went to the back after asking a series of questions to consult the "head genius" and then came back with a solution. Delete iTunes and then reinstall. After a listening to a few songs in the store/playing with some new macs, which is not really a good thing, viola, it worked!

    So, if you are having a similar problem, try deleting iTunes even if it is up-to-date and then reinstalling. I hope this helps someone else out through some hard times. :D
     
  5. madog macrumors 65816

    madog

    Joined:
    Nov 25, 2004
    Location:
    Korova Milkbar
    #5
    There are times when the Touch/Phone can hang up at some point, in which certain features won't work or will stop working until it is restarted.

    When I had that problem with my first iPhone, I would force-restart it while it was plugged into my Mac.
     

Share This Page