13" 8 GB RAM very slow in Safari.

Discussion in 'MacBook Air' started by travod, Aug 8, 2015.

  1. travod macrumors member

    Joined:
    Jun 10, 2013
    #1
    Almost every time I attempt to switch tabs the beach ball shows up for a few seconds. Yes, one of the tabs is a Twitch stream, but with this much RAM it shouldn't be an issue. Are there programs that clear out my MacBook to make it run better? Even sometimes when typing it'll just beach ball for a few seconds before all the letters come out.
     
  2. Significant1 macrumors 6502

    Joined:
    Dec 20, 2014
    #2
    What I would do. Check disk for errors in diskutil. Make sure ssd is not full. Use activity monitor and system.log messages in consol app to try narrow down the cause.
     
  3. Meister Suspended

    Meister

    Joined:
    Oct 10, 2013
  4. travod thread starter macrumors member

    Joined:
    Jun 10, 2013
    #4
    Okay, then if it is not related to RAM, what is it related to? I'd like some help.
     
  5. motrek macrumors 68020

    Joined:
    Sep 14, 2012
    #5
    Open up Activity Monitor, go to the Memory tab, and check it when the machine is running slow. If you see red in the memory pressure graph then you're running out of memory. If you don't, you aren't.

    Sometimes things are slow simply because they're slow.

    Ask your computer to compute a jillion digits of pi and it will take a while, and not because you're running out of memory.

    Maybe one (or more) of the tabs you have open is doing a lot of computation.
     
  6. krishmk macrumors regular

    Joined:
    Feb 11, 2010
    #6
    safari on citicards.com account page throws beachball at me. I look at Activity Monitor and nothing other then web page not responding.. it takes good 10 seconds to react, but as impatient as I am. i will kill the process and start over.
     
  7. travod thread starter macrumors member

    Joined:
    Jun 10, 2013
    #7
    That's the problem, I'm not asking it to do much. Sometimes I'll have only Pages open and when typing a sentence it'll freeze.
     
  8. mr.tolgao, Aug 9, 2015
    Last edited: Aug 10, 2015

    mr.tolgao macrumors newbie

    Joined:
    Oct 18, 2010
    #8
    I had the same issue (a lot of beachballs mainly on Safari). But, I have MacBook Pro 13" (Mid 2010), not MacBook Air. I had this issue, since the first version of Yosemite. I even downgraded from Yosemite to Mavericks. I still had beachballs but was less then Yosemite. I read in this forum that to do clean install of Yosemite, which I did. For a week, I did not get any beachballs after clean install. After one week, I started getting beachballs again. By the way, I also upgraded my MBP 's RAM to 8GB and HDD to SSD last year. I started thinking, my MBP is not fully capable of running Yosemite. I even bought Scannerz app to check if there was something wrong with my SSD, and also this app also checks if SSD cable is faulty or not. Anyway, all tests passed.

    By the way how much RAM, you have ?

    What version of Yosemite you have ?

    Now, I get beachballs occasionally, nothing like before.

    What helped me:

    1. On System Preferences click General and at bottom, check "Close windows when quitting an app".
    2. I did clean install of Yosemite 10.10.4 (latest version), and migrating data manually.
    3. Checking the Memory Pressure graph on Activity Monitor. When I see graph getting thicker green and yellow,
    during that time, I usually have few GBs of "Compressed Memory". When this happens, Performance of my
    Mac degrades. And I start getting beachballs.
    4. I also shut down my Mac every night. And boot again every morning. This cleans the memory every day.

    This does not mean, all these things will definitely help you. I just shared what helped me.

    T.O.



    P.S. When, I was getting alot of beachballs, I started using Chrome browser, with Chrome I was not getting any beachballs at all. But I like Safari much more then Chrome.
     
  9. motrek macrumors 68020

    Joined:
    Sep 14, 2012
    #9
    That's the only thing you have open? Not even a web browser?

    Again, check Activity Monitor and that will give you a definitive answer about whether or not you're running out of memory, and you can also check the CPU graph to see if you are doing anything CPU intensive at the time.

    Continuing this conversation before you do this is frankly pointless.

    Also BTW, it might not seem to you that you are asking Pages to do much, but it might be that Pages or OS X is doing something "behind the scenes" that you aren't aware of that's processor-intensive. Computer software is so complicated these days that it's impractical to just guess how much work the machine is doing.

    I just looked at Activity Monitor on my computer. I only have 10 apps open but I'm at 196 processes and 1199 threads. That's 1199 independent streams of instructions running on my computer right now. Lord only knows what they're all doing. I'm certain that no single person does.
     
  10. tgurske macrumors newbie

    Joined:
    Sep 2, 2008
    #10
    Go to safari -> preferences -> security and then disable the plugins. I would bet that flash is your problem. Disable it and see if I am right. If it is flash, download the "clicktoflash" or "clicktoplugin" extension to control when flash is running.
     
  11. pedro_martins macrumors member

    pedro_martins

    Joined:
    Aug 4, 2015
    Location:
    Portugal
    #11
    It is related to one thing and one thing only: Flash in Safari. Twitch uses a very unoptimized flash player that makes Safari go crazy. Use Chrome and Adblock plus for twitch.

    They are going to HTML5, but it will take a few months. Until then, do yourself and your browser a favor and delete anything flash related. Use chrome for flash.

    You could've bought a 12core 20000$ Mac Pro with dual graphics. It would deal with 25 4k html5 video streams in youtube, but it would fry itself with Twitch in Safari.
     
  12. travod thread starter macrumors member

    Joined:
    Jun 10, 2013
    #12
    I will start using Chrome then. To everyone else talking about activity monitor: I have checked it and I always have at least 3 GB of RAM free.
     
  13. MacBoook160, Aug 9, 2015
    Last edited: Aug 10, 2015

    MacBoook160 macrumors 6502

    Joined:
    Feb 9, 2011
    #13
    So interesting, travod, I've had to stop using Chrome because it's been such a CPU and energy hog. Ever since I switched to Safari, the device temperature, the processor speed, everything seems better. But I agree that Flash is also a culprit, regardless of browser.
     
  14. motrek macrumors 68020

    Joined:
    Sep 14, 2012
    #14
    Then no need to bring up RAM in the future.

    What did the CPU tab tell you?
     
  15. travod thread starter macrumors member

    Joined:
    Jun 10, 2013
    #15
    Just replicated a beach ball. Twitch stream is open in another tab. Switched tab from Facebook to Reddit and beach ball came up. At that instant I checked and it said Safari was taking up 101% of CPU. After beach ball disappeared the highest thing is flash at 22%. Safari is now at like 2%.
     
  16. motrek macrumors 68020

    Joined:
    Sep 14, 2012
    #16
    I don't know what a twitch stream is but it sounds like that site is doing something that causes Safari to block. I doubt it would be any faster on any other Mac. I assume the only way to solve the problem is to use a different browser. Maybe open your twitch stream in Chrome and all your other stuff in Safari?
     
  17. travod thread starter macrumors member

    Joined:
    Jun 10, 2013
    #17
    Now I opened Safari and Chrome, with a stream open in both. "Google Chrome Helper" is at 115% of CPU (?) and Safari flash at 75% (?). Still about 3 GB of RAM free.
     
  18. travod thread starter macrumors member

    Joined:
    Jun 10, 2013
    #18
    I'm still skeptical because this beach ball thing when changing tabs started pretty recently. It has not always been like this.
     
  19. motrek macrumors 68020

    Joined:
    Sep 14, 2012
    #19
    Every time you open a web page it downloads it from the internet. It should not be a surprise if web pages change.

    Why would you open your stream in both Safari and Chrome?

    It seems to be causing problems with Safari, so just open it with Chrome and open all your other stuff with Safari.
     
  20. pedro_martins macrumors member

    pedro_martins

    Joined:
    Aug 4, 2015
    Location:
    Portugal
    #20
    Yeah, use Safari for everything non-flash, chrome for the rest. Do you have any extensions installed in Safari?
     

Share This Page