13" Driver problems?

Discussion in 'MacBook Pro' started by jknight8907, Jun 26, 2009.

  1. jknight8907 macrumors 6502a

    jknight8907

    Joined:
    Jun 14, 2004
    Location:
    Hudson Valley NY
    #1
    Hey guys

    I just bought a new 13" Macbook Pro and did a DIY upgrade of the RAM to 4 gb and also popped in the hard drive out of my Blackbook. Everything seems to work good, except for some of the F keys. F5 thru F12 don't seem to work. The ghosted image of the command pops up but it's grey and has a (\) symbol. I'll post a screenshot if needed. Do I need to pop in the CD and do something with drivers? Thanks.
     
  2. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #2
    Does your blackbook have the different key layout?

    If so, that's your issue. You should use TimeMachine or SuperDuper or something like that to transfer your data.

    The OS from the Blackbook is a little different than that of the UMBP.
     
  3. qpid macrumors regular

    Joined:
    Oct 18, 2004
    #3
    Try an archive and install with the disks that came with your new computer.
     
  4. macunwired macrumors member

    macunwired

    Joined:
    Aug 12, 2008
    Location:
    Los Angeles
    #4
    restore disks

    Try putting the restore disks that came with your computer in and doing an upgrade (not an erase and install). That might install the missing components. Once again, don't do an erase and install (and delete all your data), just try starting up off the DVD's and upgrading the software.

    If that doesn't work, do an archive and install as qpid says.
     
  5. jknight8907 thread starter macrumors 6502a

    jknight8907

    Joined:
    Jun 14, 2004
    Location:
    Hudson Valley NY
  6. jknight8907 thread starter macrumors 6502a

    jknight8907

    Joined:
    Jun 14, 2004
    Location:
    Hudson Valley NY
    #6
    That worked perfectly. Thanks!
     

Share This Page