13" Macbook Air A1237 Mic Not working! Need help!

Discussion in 'MacBook Air' started by neorambo, Jan 24, 2012.

  1. neorambo macrumors newbie

    Joined:
    Sep 6, 2011
    #1
    Ok, I need the expertise of you guys to help me figure this out.

    I bought this macbook air a year ago with broken hinges. I fixed the hinges, and when I would boot into snow leopard the wifi and mic wasn't working. So I purchased osx Lion for it and installed that. This fixed the wifi but I couldn't get the mic to come on. So I inspected the Mic wire that goes through the hinge and noticed that it was cut a bit so I purchased the cable and replaced that and that didn't fix it.

    - went into sound settings and messed with that
    - went into Midi settings and changed the input to 48k, 44k, 98k and still nothing
    - I did the Option, P, and R keys reset and it didn't help
    - Reinstalled the OS to a clean partitioned and formatted drive
    - bought a mic and replaced that to see if that helps and still nothing.

    I can't get this stupid thing to use the internal mic. Any other suggestions besides taking it into the Apple care service tech.

    Thanks for your help in advance.
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    Does the internal mic show up in System Profiler (System Report on Mac OS X 10.7 Lion) > Hardware > Audio?
     
  3. neorambo, Jan 24, 2012
    Last edited: Jan 24, 2012

    neorambo thread starter macrumors newbie

    Joined:
    Sep 6, 2011
    #3
    Yes it does show up. When I click on the input the test volume bar goes up and then comes down.
     
  4. neorambo thread starter macrumors newbie

    Joined:
    Sep 6, 2011
  5. The 801 macrumors newbie

    Joined:
    Sep 27, 2010
    #5
    Visit genus bar. Or reload operating system, sounds like software confusion
     
  6. neorambo thread starter macrumors newbie

    Joined:
    Sep 6, 2011
    #6
    I have already reloaded the software. Doesn't work.
     
  7. Enemy75 macrumors newbie

    Joined:
    Jul 19, 2012
    #7
    Hi Neorambo,
    Did you manage to fix your problem with mic? I am experiencing exactly the same issue and tried everything including replacing the mic. Please let me know if you have succeeded or failed.

    Regards,
     
  8. luisjoujr macrumors newbie

    Joined:
    Jun 21, 2012
    #8
    Does the speaker also work or is it just the mic the one that isn't working?

    I had a similar trouble in which all the sound stopped working without apparent reason. I solved it by replacing the "Audio Flex Cable". You can find references and places to purchase one if you google it.
     
  9. Enemy75, Jul 19, 2012
    Last edited: Jul 21, 2012

    Enemy75 macrumors newbie

    Joined:
    Jul 19, 2012
    #9
    The speaker works perfectly, so we can rule this out i guess.

    I have just discovered that when I blow directly into microphone you can hear a noise in the speakers! Weird.
     

Share This Page