13" MacBook Air Wifi Hardware Not Installed after water spill

Discussion in 'MacBook Air' started by hellokaren, Nov 7, 2012.

  1. hellokaren macrumors newbie

    Nov 7, 2012
    Hello everyone,

    I have a 13' Macbook Air (10.8.2) and last week, I spilled water on top of the keyboard. However, I had a keyboard cover on it and immediately wiped the water on top away. It continued working for 10 minutes. I walked away for 45 minutes only to have my computer not working anymore, and realized there was some water that went underneath the computer. I put it in rice for 96 hours and tried to turn it on. I was excited to see that it worked, but the Wi-Fi is not working. It has the "wifi hardware not installed" error. I'm thinking this is probably something caused by the water.. Do you guys think that just the Airport/Wireless board is damaged or should I worry about the (expensive) logic board too? I have Applecare, which I realize is void because of water, but should I take my computer in to the Apple Store and say that my wifi is not working?

    I don't know what to do! Please help out, thank you!
  2. Lukewarmwinner macrumors 6502

    Oct 12, 2012
    A cheap option would be to use a wifi dongle in your USB-port. Otherwise you'll have to pay for a new wifi-card installed, which won't be covered
  3. stickyfingers85 macrumors regular

    Aug 31, 2010
    I would just take it to an Apple store and see what they say.

    Don't mention the water spill and just see what happens, you might get lucky
  4. Aperoll macrumors newbie

    Sep 14, 2014

    Ugh, yah this just happened to my 6 month old MacBook Air and I wanna die!!! I have online classes and do not know what to do..,,went to best buy and bought J5 USB 3.0 gigabit Ethernet but I don't know how to install bc it came with a cd.., duh I don't have cd drive thanks geek squad lots of help you were not!! Omg I'm crying naseous and dying inside

    What to do what do I do???
  5. DancyMunchkin macrumors member

    Mar 19, 2014
    Have you simply tried plugging in the dongle to see if it is recognized?

Share This Page