13" MacBook Pro iSight issue.

Discussion in 'MacBook Pro' started by danbeebee, Sep 30, 2010.

  1. danbeebee macrumors newbie

    danbeebee

    Joined:
    Jun 14, 2010
    Location:
    Melbourne, Australia
    #1
    I've had my 13" MacBook Pro for 10 months and I'd always tried to use the iSight with Skype here in Australia but it never worked. I just put it down to bad integration as I'd read on forums that it's a common issue.

    I finally took the MBP into Doncaster (Melbourne, Australia) Apple Store after I'd tried everything else and they gladly replaced the whole screen within the hour.

    I just wanted to say that I'm suitably impressed with the service they offered. The genius ran tests and tried to get it working and accommodated my request for a quick turnaround.

    Is this a common issue with the iSight and is this a common turnaround time for a repair?
     
  2. mulo macrumors 68020

    mulo

    Joined:
    Aug 22, 2010
    Location:
    Behind you
    #2
    the repair time is pretty common, I had a logic board replaced within 2 hours.
    there's lots of people getting the error that the camera is already in use...
    never had any problems with it myself.
     
  3. danbeebee thread starter macrumors newbie

    danbeebee

    Joined:
    Jun 14, 2010
    Location:
    Melbourne, Australia
    #3
    Yeah, the "Camera in use" message was common.

    They tested it with PhotoBooth and then booted from their own OS to see if it was a software issue. Turns out it was the hardware.

    (I also get a brand new screen which is always nice! ;))
     

Share This Page