13" Macbook Pro (mid 2012) Not detecting SSD when Internal only

Discussion in 'MacBook Pro' started by Liptonics, Dec 11, 2013.

  1. Liptonics macrumors newbie

    Joined:
    Dec 11, 2013
    #1
    Hey everyone, I'm a long time browser of these forums but I've never had to post before until I had this really odd situation.

    I recently tried to replace my HDD with a SSD in my 13" 2012 MBP. So, I bought the Crucial M500 480 GB and used Carbon Copy Cloner to duplicate my drive (and recovery partition) with the SSD in an external.

    I tested everything, verified it, and booted successfully from the SSD externally.

    However, once I swapped it out and placed it into the internal bay, it wasn't getting detected.

    I ran Disk Utility and got errors (which didn't show up when external) and decided I'd just try and erase and start over.

    So I erased, re copied, and ran into the same problem. I reset the NVRAM and still couldn't load the main partition.

    I've searched a bunch of forums and havn't really found a concrete answer for this problem. I've tried re-partitioning the drive, erasing it, making sure it's only a single partition and re-running CCC. The drive & partition also have failed to repair via Disk Utility.

    Oddly, I got the error that "The partition map needs to be repaired because the EFI system partition is too small". Which, didn't make sense since it's a exact replica of the HDD.

    I called Crucial, and they were pretty perplexed as well. They suggested that it could be the SATA ribbon cable and that it was getting interference from a nearby cable (citing a problem w/ 2009 17" Macbooks) and that I should wrap the SATA cable in tinfoil to block interference.

    I'm not that bold of a computer fixer, so the idea of adding metal into the inside chasis kind of freaked me out / scared me that I could just cause more harm than good. Plus, when searching online, I've yet to find any 2012 MBPs who had to do go through this.

    I'm wondering if anyone else has any possible suggestions as to what the problem could be or if a tinfoil wrap (or SATA cable swap) is the only real solution.

    I'm pretty much at a loss since there hasn't been too much help / support on the internet that seemed to talk about a MBP from my year with these issues. I guess I just got a bad egg :-\

    Another interesting note:
    When trying to use CCC in reverse (HDD in external and SSD in bay) it would always get hung up.

    The SSD shows up after a short period of time in finder and I can open it up and look around.

    Computer stats:
    13" Unibody Macbook Pro 2012
    16 GB Ram
    500 GB 5400 RPM HDD / (Hopefully) Crucial M500 480 GB SSD
    2.5 GHz i5

    Thanks
     
  2. cal6n macrumors 68000

    cal6n

    Joined:
    Jul 25, 2004
    Location:
    Gloucester, UK
    #2
    I've recently migrated to a 512 GB Crucial M4 in my 2012 13" MBP with no issues whatsoever.

    I didn't use CCC, though. I just took a Time Machine backup of the old system; clean-installed Mavericks via a USB thumb drive and then restored the backup.

    I know CCC is popular and you may have your own reasons for using it. I was a user for years but, since the introduction of Time Machine, I haven't found a need for any other backup/restoration solution. It's completely painless in my experience.
     
  3. josh2471 macrumors newbie

    Joined:
    Dec 11, 2013
    #3
  4. Liptonics thread starter macrumors newbie

    Joined:
    Dec 11, 2013
    #4
    Thanks so much for the replies thus far. My plan is to try doing a disk utility restore and a time machine / fresh install in the next day or two and seeing if I get results that work. I'm also planning on calling Apple in hopes of shedding some light or do anything about the cable.

    Josh2471, thanks for sharing. It's been a real struggle to find anything concrete on the internet - most message boards and such focus on older Macbooks or older SSD drives. I'm not convinced that it's an 'interference' issue as Crucial claimed, unless it's right at the cable connection point, but the idea of putting extra metal inside my machine still makes me uncomfortable.

    However, the more I think about the symptoms, the more I suspect it's an issue with the macbook itself as well, since I can't seem to find a plausible reasoning why it would load and work through an external but act so wonky once in the internal drive bay, leading me to suspect the SATA cable is a very potential culprit.

    Were both drives you used 6GB/S SSDs? I noticed my HDD gives a negotiated link speed of 3GB/s, making me wonder if an older, slower SSD would create the same problem.
     
  5. josh2471 macrumors newbie

    Joined:
    Dec 11, 2013
    #5
    I believe they are both 6Gb/s drives. I think it may be for some reason the cable is limited to 3Gb/s. That would explain why our standard drives work but not the SSDs.
     
  6. Liptonics, Dec 13, 2013
    Last edited: Dec 16, 2013

    Liptonics thread starter macrumors newbie

    Joined:
    Dec 11, 2013
    #6
    UPDATE:

    So, I really can't explain WHY things started working, but oddly enough they did. I re-installed the SSD this morning and ran the computer without the other copy of OS installed. It seemed to load up alright, but with an error on the EFI partition.

    I was able to use disk utility to repair that error and so far, knock on wood, it's been seeming to work just fine. I'm not really sure why.

    I did hear that using CCC has caused some weird location issues when the boot drive is copied while in an external bay. So it might be best to try a clean OS install and then restore from a time machine back up and see if that fixes any problems. That's what I was going to do, but ended up not needing it.

    Hope this helps someone down the road!
     
  7. Liptonics thread starter macrumors newbie

    Joined:
    Dec 11, 2013
    #7
    UPDATE 2:

    Well it must have been too good to be true. I'm pretty confident it's a cable issue at this point.

    Tried installing OS X from a USB drive (after erasing / re-partitioning the SSD) and it failed.

    The SSD clearly works, having even worked internally, but something keeps shorting it from consistently working and cooperating, so it's probably safe to assume that at this point the next logical thing to fix / replace would be the SATA cable.

    I'll update for anyone who finds this post in the future / has the same issue if I ever put a new cable in. For now, I have a HDD that works just fine.
     
  8. route2 macrumors newbie

    Joined:
    Feb 2, 2014
    Location:
    Tyler, Texas
    #8
    Curious whether you ever resolved this issue. I'm having the exact same problem and am searching for a fix.
     
  9. Liptonics thread starter macrumors newbie

    Joined:
    Dec 11, 2013
    #9
    Hey, so the issue ended up being the SATA cable that came with my macbook pro. I ended up going to the apple store and the genius did a couple tests with me, swapping my SSD into one of their other computers to see if the problem was there.

    Turned out that the SATA cable was the problem. In any case, the genius replaced it for me and charged only for the parts (it was roughly $18) and everything seems to work just fine for the past few months. Load times are insane!

    Good luck!
     

Share This Page