13" MacBook Pro Sound Problems

Discussion in 'MacBook Pro' started by simplymuzik3, Jul 26, 2009.

  1. simplymuzik3 macrumors 6502a

    Joined:
    Jan 29, 2009
    #1
    Okay, so I'm having a small problem with my macbook pro 13". It's the stock config 2.26, but with the 250gb hard drive. So here's my problem:

    When I watch movies/youtube videos, listen to music, or anything with audio it plays perfectly from the macbook's speakers. However, when I plug in speakers, headphones etc, the volume buttons get disabled. When I press the buttons the volume shows up on screen but there's a line(like when you're unable to change keyboard backlight). So that's the first problem. Then, I can turn off the computer, plug something into the audio jack and turn it on again. If the speakers/headphones are plugged in when the laptop first turns on, then it works through the headphones/speakers. When I do this, it works for a little while (hour or sometimes more/less), then the audio starts to cut out randomly. Eventually it starts to cut out every few seconds, then come back for another few seconds.

    So, is anyone else having this problem? Am I the only one? Should I take it to apple? I got it less than a month ago from apple.ca. Can I just call and book an appointment to take it to the apple store? Could it just be a software problem? Please let me know what you think about this. Thanks for reading it all!
     
  2. t3heford macrumors member

    Joined:
    Jul 1, 2009
    #2
    Definitely not normal behavior. I suggest you call apple tech support/genius w/e they're called, just to see if they have any recommendations. If they don't then they can schedule an appointment for you, on the phone.
     
  3. simplymuzik3 thread starter macrumors 6502a

    Joined:
    Jan 29, 2009
    #3
    okay, thanks. I'll schedule one this week. I just wanted to make sure that it wasn't a common problem or something.
     

Share This Page