13" MBP 2012 Waking VERY SLOW After most recent update?

Discussion in 'MacBook Pro' started by TechieGeek, Nov 14, 2012.

  1. TechieGeek macrumors member

    Joined:
    Mar 12, 2012
    #1
    There was an update that came out a few weeks ago for the 2012 MacBook Pros. Ever since then, when I wake up in the morning and open up my computer, the SuperDrive makes a sound (as if the computer is booting up) and then I see the login screen greyed out as a progress bar progresses at the bottom of my screen. Even after its gone, my computer lags for a while and I can't even move the mouse. Eventually, it'll let me enter my password and log in.

    What's going on? Does anyone else have this issue? I like how it was before, where I could shut my laptop, then open it an go right back to work after a sign-in. This has happened on multiple days for me and it feels like it slows my computer down a lot (and it only happens after the computer has been shut for an extended period of time) yet there's nothing running in the background.

    If I close the laptop and come back to it soon, it'll behave normally and it won't lag on me.
     
  2. chriscl macrumors 6502

    chriscl

    Joined:
    Jan 4, 2008
    Location:
    Stuttgart, Germany
    #2
    Yes, several of us have it - see the discussion thread here:

    http://forums.macrumors.com/showthread.php?t=1486234

    What seems to be happening is that after 1-2 hours of 'sleep', the MacBook Pro is actually hibernating, and what you hear (the tone) and the delay in resuming is caused because it is resuming from hibernation, which takes longer than simply resuming from sleep.

    Not sure why the behaviour changed in the new update, nor if it is possible to revert to the previous behaviour!
     
  3. aircanman macrumors 6502

    Joined:
    Feb 2, 2011
    Location:
    UK
    #3
    I have this and have started a thread about it, I was on the phone to Apple technical support earlier and he said it is the first time he has come across it before. Mine is a brand new 2012 MBP but I have put 8GB of aftermarket ram in it which I thought may be the problem, do you have the original or aftermarket RAM in the computer?
     
  4. CausticPuppy macrumors 65816

    Joined:
    May 1, 2012
    #4
    One workaround seems to be to increase the standbydelay to a much larger value than the default (which is 70 minutes).

    From terminal:

    pmset -g | grep standbydelay

    This will show you the default which is 4200 seconds.

    I've set mine to 24 hours. If you don't do anything to your sleepimage or hibernate mode, that just means that your system will hibernate after 24 hours of being asleep, instead of 70 minutes.

    sudo pmset -a standbydelay 86400


    The latest update also seems to have a bug/feature where your system seemingly ignores the hibernatemode value and always enforces safesleep.
     
  5. chriscl macrumors 6502

    chriscl

    Joined:
    Jan 4, 2008
    Location:
    Stuttgart, Germany
    #5
    You raise a very good point - I can't help but wonder that as my MBP has previously always seemed to ignore this 70-minute cutoff (and just "slept" instead of hibernating) that perhaps this update has actually "fixed" a previously-broken behaviour, by actually forcing the MBP to hibernate instead of sleeping!

    I'm sure Apple will sort it, one way or the other...
     
  6. TechieGeek thread starter macrumors member

    Joined:
    Mar 12, 2012
    #6
    I haven't changed anything hardware-wise.

    I have the 2012 13" upgraded version (with 8GB RAM and the 2.9GHz dual-core i7).

    ----------

    So will this change the delay after which the computer goes to standby? I've changed my "Computer Sleep" values in System Preferences to 15 minutes on battery, and never when plugged in. And of course it sleeps every time I close the lid.

    Also, is there any reason why the computer would want to hibernate at all? Is it just to save battery power (save more than when it sleeps)?
     
  7. CausticPuppy macrumors 65816

    Joined:
    May 1, 2012
    #7
    That's a different setting. The System Preferences setting controls how long the machine will stay awake while it's idle. That means if you don't touch the machine for 15 minutes, it will go from awake to asleep.

    When asleep, your system is still providing power to the system memory so that it can wake up very quickly. However, it has also written the contents of memory to disk just in case it loses power completely, or goes into suspend mode.


    The "standbydelay" parameter isn't available in system preferences. Once your machine has already gone to sleep, it will wait the additional 70 minutes before powering off completely. Then, when you open the lid, it has to read the memory image off of the disk again, which is why it takes a bit longer and you see the progress bar.

    Presumably to save battery life. As Apple makes more computers with SSD storage, waking from suspend mode is much faster than it is with a regular hard disk. I think they are moving in a direction with their computers where they aren't meant to be turned on/off, just like your iPad. Either you're using it, or it's in standby mode.
     

Share This Page