13" mid 2010 no backlight

Discussion in 'MacBook Pro' started by mwillson, Sep 24, 2014.

  1. mwillson macrumors newbie

    Joined:
    Sep 24, 2014
    #1
    Hey there, would love some help on this one guys.

    I have a macbook that recently had a magnet missing inside the screen assembly, so it wasn't going to sleep. However, everything else worked fine - until, of course, I put the new magnet in and put everything back together. No backlight.

    First things first: checked external monitor. Good.
    Next: happened to have the body of another 13" macbook lying around sans screen assembly, so i hooked this one's assembly up to it... and whaddya know, its working fine, backlight and all!

    So, I know this: a) video card/circuit works. b) display assembly, including lvds cable, works.

    The display cable connector on the motherboard looks fine and I don't see any glaringly obvious blown components anywhere near it. I did go into the OS and try to increase the brightness through the system preferences, but the slider accomplished nothing. Also, the brightness keys on the keyboard do nothing as well.

    I feel like I can't even know if its a software or hardware issue unless I have some specialty tools from apple themselves, although it did only happen after I messed with the hardware a bit, so that might be a clue. If anyone can help me figure this one out, has had a similar issue of sorts, or just happens to know what components are involved between the suspect areas, its really appreciated. Thanks.
     
  2. mwillson thread starter macrumors newbie

    Joined:
    Sep 24, 2014

Share This Page