13'' Unibody Macbook Pro Headphone/Speaker "Delay" Problem

Discussion in 'MacBook Pro' started by thedarkchariot, May 31, 2010.

  1. thedarkchariot macrumors newbie

    Joined:
    Feb 21, 2010
    #1
    Hey guys.

    Searched around on MR a bit, but I didn't find anything, so excuse me if there is already a thread for this. I just bought my Macbook Pro yesterday and I've noticed this problem. When I plug in my headphones, music still keeps playing in the external speakers for a good 3 seconds or so - that is, plugging in my headphones is not instant. Same goes for plugging out my headphones. Does anyone else have this problem?

    Should I return the laptop or is there some way to fix this?

    Thanks everyone!
     
  2. cloroxbleach4 macrumors 6502a

    cloroxbleach4

    Joined:
    Dec 28, 2007
    Location:
    Oklahoma
  3. khunsanook macrumors 6502

    khunsanook

    Joined:
    Jul 2, 2006
    Location:
    East Asia
    #3
    same here. 13" 2010 MBP. Didn't really think much of it though.
     
  4. Fuzz02 macrumors newbie

    Fuzz02

    Joined:
    May 26, 2010
    #4
    The 13inch macbook pro has one jack for line in and audio out. Whenever you plug something in, I suppose the computer checks and sees what it needs to change the jack to and it takes it a second or two.

    I haven't checked, but perhaps there is a way to make it audio out only?

    Honestly, it's my only gripe with this computer. I no longer can plug in my guitar and jam with headphones/speakers like I used to, or record something and then have headphones and rerecord over it to monitor the sound properly while playing.

    May end up looking into a splitter..
     

Share This Page