141 Does not withhold number on O2

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Barry Scott, Dec 17, 2007.

  1. Barry Scott macrumors newbie

    Joined:
    Nov 20, 2007
    #1
    I called a colleagues work's mobile with my iPhone and the number had 141 in front of it.
    To my astonishment, my number came up on his display :eek:

    I wonder if the 'Show My Caller ID' completely overrules the prefix of 141?
    Mine is set to show - but it was on my previous phone - and typing 141 always used to withhold the number.

    Has anyone else come accross this issue?
     
  2. Barry Scott thread starter macrumors newbie

    Joined:
    Nov 20, 2007
    #2
    Eureka! I've just answered my own query - I saw another post which states the GSM standard allows you to type #31# before the number you wish to dial and it nicely withholds your number!

    I have just tried this and it worked a treat.
     
  3. splashtech macrumors regular

    Joined:
    Oct 25, 2007
    #3
    Great! Thanks for that! I've always had to go into the settings on my phone (T-Mobile/UK) to get that to work. 141 worked on my old Orange pay-as-you-go, but not on O2. I will try this now I think... :)
     
  4. Prince Charles macrumors newbie

    Joined:
    Dec 2, 2009
    #4
    Thank you so much for that! Been looking everywhere.

    Mark
     
  5. nomad01 macrumors 68000

    nomad01

    Joined:
    Aug 1, 2005
    Location:
    Birmingham, England
    #5
    Don't get it...

    Show My Caller ID is set to ON on my iphone.

    I've dialled a land line with 141 at the start and it's witholding my number as I'd expect it to.

    :confused:
     

Share This Page